PDA

View Full Version : [mythbuntu] Disable DPMS



CNLiberal
August 22nd, 2008, 01:05 AM
I have an AGP nVidia FX5200 using DVI out to an Acer 22" LCD. I want to disable DPMS so that the screen never turns off. How can I do this? I've tried an experiment where I put an option in the xorg.conf that says:

Option "DPMS" "Disable"

I doubt it's correct. Anyone have any ideas for me? Thanks!

Posting xorg.conf below


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Thu Jun 5 09:26:53 UTC 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer X223W"
HorizSync 31.0 - 84.0
VertRefresh 56.0 - 77.0
Option "DPMS" "Disable"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "ModeValidation" "NoMaxPClkCheck"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5200"
Option "ModeValidation" "NoMaxPClkCheck"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP: 1600x1024 +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: 1680x1050 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

kpkeerthi
August 22nd, 2008, 08:21 AM
It should be in your Device section, like so



Section "Device"
Identifier "NVIDIA GeForce 7800 GTX"
Driver "nvidia"
Option "DPMS" "FALSE"
EndSection

... and then restart 'X'.

Or the easiest way is to turn off Monitor Shutdown/Standby in your Screen Saver preferences under System -> Admin. I personally use xscreensaver, but Ubunty comes with GNOME Screen Saver by default. No I'm not sure how the options are laid out in Hardy.

CNLiberal
August 22nd, 2008, 02:45 PM
Thanks, I'll give that a try. I can not go into System -> Admin because this machine is running XFCE and not Gnome. I'll let you know how it works out.