PDA

View Full Version : [ubuntu] USB problems -> USB mouse and joypad not working / detected



MASEngr
August 21st, 2008, 09:54 PM
Hi everyone.

I'm using 8.04 on a fresh install. I am unable to detect the joypad or the USB mouse. I had to install fresh due to a hardware problem and upgrade.

The joypad is a critical part of a work machine, used to manually control a milling machine. I cannot get the mill to run without the joypad.

The joypad is a Logitech Dual Action, and it is known working good. THe USB mouse is a generic HP mouse, which was working with this installation a few times. Nothing changed, but now it stopped working and I plugged in a PS/2 mouse. That, at least, works.

I have installed the joystick modules (joystick / jscalibrator) and the evdev drivers. There was no change.

Here is the output from sudo lsusb. Note that it's blank.
cnc@cnc-control:~$ sudo lsusb
cnc@cnc-control:~$

Here is xorg.conf:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection


I tried the command suggested:
cnc@cnc-control:~$ sudo dpkg-reconfigure -phigh xserver-xorg
xserver-xorg postinst warning: overwriting possibly-customised configuration
file; backup in /etc/X11/xorg.conf.20080821134821
FATAL: Module battery not found.

I'm not sure what it's talking about here.

I can't use an older version of the kernel because the SATA drive doesn't work on older versions. I've tried and it doesn't mount the hard drive.

If I could get some insight as to how to install this joypad, I'd really appreciate it. I've got a dead machine here and a few guys standing around waiting for me to fix it.

Thank you.

MASEngr
August 21st, 2008, 10:10 PM
ADDENDUM:

A little more searching, and I've run the following commands:

sudo update-usbids

Which updated the USB ids, but didn't change the "not working" aspect.

I also tried the following:
cnc@cnc-control:~$ lsusb -v
cnc@cnc-control:~$ dmesg | grep usb
[ 209.235308] usbcore: registered new interface driver usbfs
[ 209.235325] usbcore: registered new interface driver hub
[ 209.242154] usbcore: registered new device driver usb

cnc@cnc-control:~$ sudo rmmod echi_hcd
ERROR: Module echi_hcd does not exist in /proc/modules

cnc@cnc-control:~$ dmesg | grep -i hci
[ 209.242761] ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
[ 209.242791] ohci_hcd 0000:00:0b.0: Found HC with no IRQ. Check BIOS/PCI 0000:00:0b.0 setup!
[ 209.242796] ohci_hcd 0000:00:0b.0: init 0000:00:0b.0 fail, -19
[ 209.243830] ehci_hcd 0000:00:0b.1: Found HC with no IRQ. Check BIOS/PCI 0000:00:0b.1 setup!
[ 209.243834] ehci_hcd 0000:00:0b.1: init 0000:00:0b.1 fail, -19
[ 222.617301] Bluetooth: HCI device and connection manager initialized
[ 222.617304] Bluetooth: HCI socket layer initialized

I'm not using Bluetooth for anything, so I'm not sure why it installed.

Thanks again for any help.

MASEngr
August 21st, 2008, 11:15 PM
UPDATE:

By mucking with the BIOS settings:

PnP OS: Disabled
USB legacy: Disabled

I'm not sure which of these was critical, but I think it was the PnP OS, as I already tried the USB legacy settings. It may or may not be the combination of the two.

I was able to see the joypad:
cnc@cnc-control:~$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 046d:c216 Logitech, Inc. Dual Action Gamepad
Bus 001 Device 001: ID 0000:0000
cnc@cnc-control:~$

And jscalibrator shows it as /dev/input/js0, which is great. I just have to get the application to recognize it.

I can't get the mouse to work yet either. That's lame, but at least that's livable. I have a PS/2 mouse that I can use instead.