PDA

View Full Version : [ubuntu] [SOLVED] Sound is MESSED UP! PLEASE HELP!!!



Archie69
August 11th, 2008, 03:46 AM
Hi again,

I posted here a day ago cause I'm having a little difficulty with the set up of ubuntu an my Acer Aspire 5920. I seem to have everything installed properly however there seems to be a problem with the sound card.

The card is an "Audio (Intel High Definition Audio (HDA))"

The most info I found on its problems were:
"Sound works but plugging a headphone does not mute front speakers, no solution for Virtual SurroundSound

Internal microphone outputs to speakers but capture does not work"

Is there anything I can do to resolve this issue because I am goin out of my mind, or is this sound card just a lemon on ubuntu?

Thanks

Locutus_of_Borg
August 11th, 2008, 03:53 AM
your problem is that plugging in head phones does not mute the speakers?

Archie69
August 11th, 2008, 04:01 AM
There are a host of problems, however this is the most information I have found regarding this specific model. As of now sound is not functioning period.

I'm also looking at this link:

https://wiki.ubuntu.com/LaptopTestingTeam/AcerAspire5920G

I appreciate the help.

Locutus_of_Borg
August 11th, 2008, 04:16 AM
Try the following:


sudo -i
alsaconf
alsamixer
modprobe snd_hda_intel
usermod -a -G audio YOUR_USER_NAME

See if any of that helps

Archie69
August 11th, 2008, 04:40 AM
YOU ARE AWESOME PAL.

Sound works great.
Thanks a lot.

Locutus_of_Borg
August 11th, 2008, 04:48 AM
okay good, now to make sure it works after a reboot, do this:


sudo echo "snd_hda_intel" >> /etc/modules
sudo alsactl store

this will make sure your volume settings get saved, and the correct module for your soundcard get loaded at boot. I am not positive that the alsactl is even needed, but it can't hurt to be safe

fenT1
August 11th, 2008, 04:53 AM
Try the following:


sudo -i
alsaconf
alsamixer
modprobe snd_hda_intel
usermod -a -G audio YOUR_USER_NAME

See if any of that helps

ok im in the dark the whole code ina single line?

Locutus_of_Borg
August 11th, 2008, 04:57 AM
ok im in the dark the whole code ina single line?

each line seperately

sudo -i opens a root shell

alsaconf configures alsa and your soundcard, it will create a menu where you basically just press yes for everything

alsamixer lets you change volume, just make everything as high as it can go

modprobe snd_hda_intel loads the module for the intel soundcard

usermod adds a user to a group, in this case the audio group

Archie69
August 11th, 2008, 05:16 AM
Wow, I spoke too soon.

Alright... Basically... this was done

In volume control make sure that in File -> Change device the "HDA Intel (alsa mixer)" is selected.
Go to Edit -> Preferences and select all tracks in the list.
Unmute and increase volume on "PCM", "Surround", "Center", "Side" and "LFE". Sound should work nicely now. Optionally mute the micophone sliders.\

to resolve the "no sound" issue but now I cant get sound from the working speakers.

Archie69
August 11th, 2008, 05:19 AM
That didn't make much sense now hat i read it. Basically, sound comes from the speakers from the notebook but nothing happens when I plug in external ones. What could cause that?

Vaedrah
January 11th, 2009, 10:22 PM
Hi Loctus_Of_Borg et al

I have a similar audio problem with an acer aspire 5920 in that the internal speakers no longer work. I tried your commands in the terminal box;

sudo -i
alsaconf
alsamixer
modprobe snd_hda_intel
usermod -a -G audio YOUR_USER_NAME

but alsaconf refused to acknowledge any file. Also alsamixer bought up a graphical display but the sliders don't respond.

The headphone works with external speakers.

The notebook used to run Vista but then I managed somehow to loose its hard drive. This had 2 main partitions and two knobby end ones. I suspect one of these lost its contents. After than I couldn't reinstall windows but Ubuntu 8.04 seems to work. However the internal speakers didn't work.

I've also tried Sun VirtualBox on top of Ubuntu but that also didn't work (I has problems seeing the DVD drive). I am quite "green" with s/w so I appreciate any suggestions.

Thank in advance!