PDA

View Full Version : [ubuntu] mounted partitions on desktop as icons



Jeenyus
August 10th, 2008, 09:00 PM
I have 2 partitions (Windows XP and a shared FAT32) that I have set to automatically mount on boot. However I don't like that they show up on my desktop as icons, is there a way to still have them mount automatically without showing up as icons on the desktop?

Thank you

Vivaldi Gloria
August 10th, 2008, 09:04 PM
I have 2 partitions (Windows XP and a shared FAT32) that I have set to automatically mount on boot. However I don't like that they show up on my desktop as icons, is there a way to still have them mount automatically without showing up as icons on the desktop?

Thank you

Mount them to /mnt/mountpoint in fstab. First create the folders in /mnt. Then modify fstab. Then restart.

They wont make desktop icons. You can symlink them where ever you want.

SZ07
August 11th, 2008, 01:00 AM
Here is another way:

Open up the gnome Configuration Editor. Expand apps and then nautilus. Click on desktop and, in the pane on the right, uncheck volumes_visible.

Vivaldi Gloria
August 11th, 2008, 08:08 AM
Open up the gnome Configuration Editor. Expand apps and then nautilus. Click on desktop and, in the pane on the right, uncheck volumes_visible.

That's possible but it also stops usb disks and cd-roms to appear on the desktop.

!ndy
August 11th, 2008, 08:46 AM
i've saved this super console trick, so i can try to impress people with it ;-)


gconftool-2 --type bool --set /apps/nautilus/desktop/volumes_visible 'false'

it's for the /media/disk/ icon...