PDA

View Full Version : [gnome] All file associations are gone



cyrus_the_virus
August 10th, 2008, 05:54 PM
Hi,

In my ubuntu 8.04 installation the file associations are broken for basically every filetype. If I double click on a file (a jpg for example) it says there's no applications installed for this file type. When right click on the file and do a open with...-> image viewer it works and remembers it. But nautilus doesn't show any preview of picture or video files (not even after I restored the file association with 'open with')
Also I noticed all mp3 files have a executable icon instead of the usual mp3 icon in nautilus.

I tried to create a new user account and login under that but I have the same problem then.

Any ideas what could cause this and how to fix it?

Thanks,
Marty

cyrus_the_virus
August 11th, 2008, 09:28 AM
I have noted some other 'weird things' that might be related to the problem:
- If I drag an program from the applications menu to my desktop I get a .desktop file on the desktop with a textfile icon instead of a normal shortcut with an application icon
- On my ntfs partition a lot of files are executables
- All files have default text file or exe icons instead of an icon that fits the file type (picture have picture icons...etc). Also there a no previews available in nautilus (I have set nautilus to make always previews of files up to 100 MB)


Can anybody help me? I'm using ubuntu 8.04 64 bit and I have installed all updates.

Thanks,
Marty

SoccerCore11
August 31st, 2008, 04:39 PM
I have this exact same problem, any help would be greatly appreciated.

lvlo
August 31st, 2008, 05:11 PM
I had problem like this some time ago, for more info see this thread (http://ubuntuforums.org/showthread.php?t=868218).

Run this in terminal:
sudo update-mime-database /usr/share/mime
and maybe one more command:
update-mime-database ~/.local/share/mime/

kleskjr
November 3rd, 2009, 09:23 PM
have the same problem but this solution doesnt work for me. Did what lvlo said but nothing happened

lvlo
November 3rd, 2009, 09:33 PM
If you are running Karmic, check these threads:

http://ubuntuforums.org/showthread.php?t=1284721
http://ubuntuforums.org/showthread.php?t=1284510