View Full Version : [ubuntu] keyboard problems

July 29th, 2008, 02:08 PM
I was using my home-town slovenian keyboard configuration, but it got blown up and now... OMG
QWERTZ still works (instead QWERTY, witch we don't use), and most of other options, but some of others like j ; č ; ; ; @ and some others.
I went into preferences -> keyboard but there is nothing I can do. I think somethinge in here is wrong and how can I fix this.
And the picture:
http://shrani.si/t/2L/kL/gkGsGrE/screenshot.jpg (http://shrani.si/?2L/kL/gkGsGrE/screenshot.png)

Het Irv
July 29th, 2008, 02:32 PM
You can try editing your xorg.conf file,

gksudo gedit /etc/X11/xorg.conf

In the part that has the keyboard configuration there should be a line that says
Option "XkbLayout" "us"
Try changing the us to your countries two letter code. That might fix your problem.

July 29th, 2008, 07:36 PM
Doesn't work, becouse the two letters (si in this case) are already at place. Is there posibility that cause for this is installing and configuring VirtualBox?

July 29th, 2008, 09:44 PM

July 29th, 2008, 11:24 PM
I am sorry for spamming, but I really need this to work, so if any idea rather then reinstall ubuntu is in place I would be thrilled to hear it.

July 29th, 2008, 11:40 PM
Ok, I am spamming again but i figured out somethinge.
For everyone: The only thing to do is to run this:

sudo xmodmap /usr/share/xmodmap/xmodmap.uk
And change last two letters into what you need for your language. Well this is second time I saved somethinge whitout help of yours so congrats to me:).

Het Irv
July 30th, 2008, 04:53 PM
Sorry about that ozbolt, had get offline. Glad you got it fixed. Please mark your thread as solved, so that others can benifit from this thread.

August 11th, 2008, 07:01 PM
Great, thank you.

What are we doing with that command? I like to know what I do :)

Is there a way to have this as a permanent solution, without having to do the terminal command every time?

I tried with sessions putting the command you give us, but it will not work starting the session.

Thank you again.

update: I took away the sudo before the command line in session startup script and it worked.