View Full Version : [ubuntu] [SOLVED] Error Msg with Synaptic Package Manager

July 24th, 2008, 08:38 PM
When i try to open the SPM it says: "An error ocurred"
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

And cant install another programs because says: "Only one software management tool is allowed to run at the same time."

Any help?!

July 24th, 2008, 08:40 PM
did you run

sudo dpkg -configure -a

from a terminal?

July 24th, 2008, 08:42 PM
First you can only have synaptic, add/remove or be doing an apt-get or aptitude in the terminal one at a time if you get the "Only one software management tool..." error you either have more than one open or a previous one has not closed properly.

sudo dpkg --configure -a for the first error you have

July 24th, 2008, 08:48 PM
Yes and already typed dpkg -help but dont know what to do next

July 24th, 2008, 08:51 PM
Run the command in a terminal.

July 24th, 2008, 09:04 PM
Done... just had a broken filter (sun-java-...) and the problem is fixed.
Thanks for the help forrest

July 24th, 2008, 09:28 PM
Welcome - cna you mark thread solved