PDA

View Full Version : [ubuntu] [SOLVED] music players won't play anything



ELD
July 23rd, 2008, 10:22 AM
Any idea how i can find out why none of my music plays?

northern lights
July 23rd, 2008, 10:29 AM
Do the players complain or do you not have audio output? I.e. if you double-click an .mp3, does it open in aplayer and does the slider move?

Did your music ever play before on your current install?

1. As for players, not opening the files:

Do you have the package "ubuntu-restricted-extras" installed?
--> You can check in Synaptic or run
aptitude search ubuntu-restricted-extras and check whether it's flagged as "i".

2. In case of missing output:

Maybe something's muted (simple, but happens). Run "alsamixer" in a terminal and check. "MM" stands for muted...

Do you have multiple sound cards? Please post the output of
cat /proc/asound/cards

rockerphil
July 23rd, 2008, 10:39 AM
my suggestion would be to check the alsa mixer GUI, if you don't have it installed you can install it from Synaptic or the command prompt with:

sudo apt-get install alsagui

then make sure as stated above nothing is muted, hope it helps, and much luck,


Phil

----------------
Now playing: South Park Mexicans (SPM) - You Know My Name (http://www.foxytunes.com/artist/south+park+mexicans/track/you+know+my+name)
via FoxyTunes (http://www.foxytunes.com/signatunes/)

ELD
July 23rd, 2008, 11:30 AM
Strange rebooting fixed it.

billgoldberg
July 23rd, 2008, 12:03 PM
Could it be related to the pulseaudio + flash bug?

Try switching to ALSA instead of pulseaudio (default) in "system -> preferences -> sound".