PDA

View Full Version : [ubuntu] Help with eKiga incoming call (pulseaudio or network problem?)



davidonlaptop
July 23rd, 2008, 04:28 AM
Hello!

I am trying to configure eKiga/Gizmo (call-in) and Skype (call-out) to work together with pulseaudio (or something else as long as the sound card can be shared).

eKiga used to work (via STUN server), but Skype was only working when the file /etc/asound.conf was empty and no flash application were playing. So I followed these guides :

https://wiki.ubuntu.com/PulseAudio
http://ubuntuforums.org/showthread.php?p=4928900 (part A,C)
http://www.pulseaudio.org/wiki/PerfectSetup#ALSAApplications

(and upgraded my kernel from 2.6.24-16-generic to 2.6.24-19-generic, hardy 8.04).

And now Skype works great, but I can't receive any call on eKiga/Gizmo. I get no ring, and no error. I can play sounds in eKiga (Preferences / General / Sound Events / play), but if I do :


arecord -D plughw:0,0 -c 1 -r 8000 -f S16_LE - | aplay -D plughw:0,0 -c 1 -r 8000 -f S16_LE -

while another application is using the sound card, it says : "aplay: main:546: audio open error: Device or resource busy"...

How to know if the problem is coming from pulseaudio / Gizmo network / kernel upgrade / conflicting files / etc ?

I've spent a 4h+ reading on this, and I am humbly a confused...

Also, is there a simpler setup? Is pulseaudio really necessary to share the sound card between applications?

Thanks,

David

oliviacond
July 24th, 2008, 12:58 PM
i also have audio problem caused by pulseaudio.
i switch it to ALSA