View Full Version : [ubuntu] Intall hangs on Format Swap space

July 22nd, 2008, 06:24 AM
I have tried to install Ubuntu Desktop on my laptop to duel boot with WinXP. I started the installer in windows, rebooted and continued until it hung up on the part that says it formatting swap space (or swap partition). I let it sit for maybe an hour last night and it never finished.

Any ideas on why it's doing this?

July 22nd, 2008, 07:21 AM
you try to manually encrypt swap upon installation?

July 22nd, 2008, 07:41 AM
This was my first attempt at installing it. I'm not sure how i'd manually encrypt the swap like you are asking.

I've since done a clean install on a separate box with no problems.

July 22nd, 2008, 07:50 AM
well, did it freeze when you tried to manually encrypt swap?

July 22nd, 2008, 02:30 PM
I dont know how to manually do anything yet. this was just in the installer process.

Would doing that part manually fix it?

July 22nd, 2008, 02:32 PM
well, it is a known bug that it hangs upon manually assinging a random key for swap encryption. Hence my questions. Besides that, it should not hang. Did you check the cd for defects?

July 22nd, 2008, 02:39 PM
I started the installer from a mounted ISO inside WinXP then it rebooted me to the installer. Should I try again by booting to the a CD?

July 22nd, 2008, 03:23 PM
run it from inside XP? Is that possible at all?

Boot from the cd.

July 22nd, 2008, 03:31 PM
Yes, it copies the necessary files to the HD and configures the boot menu to give you the option of windows or ubuntu.

After it does that, it asks you to reboot and at the boot menu if you select ubuntu it will continue the installer.

July 22nd, 2008, 03:36 PM
oh, that's how the wubi installer works... I'd rather suggest to do a real install ;)

can't help you much with wubi... I try to avoid is as much as possible ;)

July 22nd, 2008, 03:57 PM
ha ha okay, i'll give it a whirl and see if I can't get it to work.

July 22nd, 2008, 06:43 PM
just two things:

(1) you need to partition so defrag windows 2-3 times

(2) upon installtion - especially the partitioning part - just don't press "ok", "ok", "ok"... have a read ;)

March 6th, 2009, 01:16 AM
I have had the same problem...both with ubuntu and kubuntu
after I converted my fat32 fs to ntfs
because with fat32 the kernel cannot update