PDA

View Full Version : [ubuntu] x11 bad quality



clinux
July 21st, 2008, 05:06 PM
I'm using x11 as video output and when i use a bigger resolution than the current video, i have bad quality. I'm using VLC
here is my xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Tue Jan 22 19:53:46 PST 2008

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Tue Mar 4 20:24:34 UTC 2008
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Generic Keyboard" "CoreKeyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Proview"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce4 Ti 4200 with AGP8X"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1024x768_85 +0+0"
Option "AddARGBGLXVisuals" "True"
Option "AddARGBVisuals" "True"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

sisco311
July 21st, 2008, 05:12 PM
try to change the video output to xv, gl or gl2.
with the restricted nvidia driver mplayer works great(on my system) with gl2.

clinux
July 21st, 2008, 06:26 PM
Xv is not compatible with compiz.

sisco311
July 21st, 2008, 06:33 PM
did you try gl2 ?

clinux
July 21st, 2008, 07:25 PM
yes.
and btw i've found this, but i'm using nVidia http://ubuntuforums.org/archive/index.php/t-111181.html

clinux
July 21st, 2008, 11:46 PM
Ok, i completely uninstalled and reinstalled MPlayer and SMPlayer. Now with x11, SMPlayer works like a charm.