View Full Version : [ubuntu] Firefox died on 'partial upgrade'

Mr Tim
July 13th, 2008, 02:56 AM
The following happend:
1 - When installing updates (XULrunner being among them) it asked me if I wanted to do a partial upgrade, I pressed yes.
2 - I clicked through the upgrade.
3 - On completion I tried opening firefox, I discovered it wasn't there.
4 - I tried to install it using add/remove programs and it said there were some unresolved dependencies, and to try installing through synaptic.
5 - I tried installing through synaptic, but it said XULrunner 1.9 could not be installed.
6 - I looked at XULrunner 1.9 and it was already installed, I clicked uninstall (with the intention of reinstalling it later) but it was wanting to uninstall various packages with it including 'ubuntu desktop'.

Please help... I really want firefox back, while I installed epiphany in its place it's just not the same.

July 13th, 2008, 03:12 AM
I've just had a similar problem which resulted in firefox 3 getting removed (along with all my favorites), and am now unable to reinstall it without removing ubuntu-desktop. Looks like there's a dodgy update going around or something.

I'm back on windows until it gets fixed.

July 13th, 2008, 03:31 AM
me three. Exact same scenario as original post

July 13th, 2008, 06:43 PM
me four!!!!

has anyone found a solution yet?
also what was the cause? why was firefox removed?:confused: