View Full Version : [ubuntu] [SOLVED] Problems with gnome: taskbars not working.

July 12th, 2008, 10:07 PM
Hello. I'm having a rather length problem with 8.04.

I booted up today to find that my taskbars and menubars were gone. I don't know how to restore them, and many things arent working.
It seems I cannot create a launcher on the desktop (I can right click and get menu but when I click 'create launcher' nothing happens, the rest of the menu items work fine.)
I am no longer connecting to the network, so I can't check my packages. (The network icon is on my taskbar so i can't troubleshoot it because the taskbar is gone.)
alt f2 and alt f1 do nothing
if ctrl-shift-t is the correct combo for opening a terminal, it doesnt work (i can get there through folders on my desktop - my desktop icons are about all thats intact)

I think I may have accidentally upgraded the wrong package or uninstalled it or something. I was installing a few programs yesterday and their dependancies, so I really don't know what it was. My best guess from my symptoms is that somehow I screwed up gnome.

Here's what I (think I) installed:
thunderbird - worked
lightning (tbird ext)- didnt work
uninstalled evolution and perhaps its dependancies as well
I might have done something with xfce, I don't quite recall

So, if you managed to get through that incredibly poor explanation, I was wondering if I can use the liveCD to reinstall the default packages onto my hard disk installation. That way my programs and settings stay intact.

Or maybe I should try something else? Seeing as how alt-f2 is broken and my menubars dont work, should I try just reinstalling gnome (I assume these symptoms belong to the desktop environment)?


P.S. If you think you can help me but need more info, just let me know what you need. I'm not too linux-savy so you'll have to tell me if/which logfiles to post.

Edit: Bah. It was a gnome problem. I accidentally uninstalled part of it.