PDA

View Full Version : What didn't work out-of-the-box with your Linux rig?



VitaLiNux
July 9th, 2008, 09:51 PM
Well, the only thing that didn't work right out-of-the-box was a PSX-2-PC USB adapter, which I had used before to play SNES games in my rig.

List of the things that worked out-of-the-box:

* Wireless keyboard Genius mdl. no. GK-04004/k
* LCD mon. 19 SOYO widescreen
* DRVrw Dual Layer LG 24x
* Printer HP Photosmart D7100 Series
* Generic Bluetooth Dongle
* Kodak EasyShare camera
* GE USB mouse

Almost every single thing I plug into mi PC works without hassle.

elmer_42
July 9th, 2008, 09:53 PM
The only thing that didn't work was my WiFi card. Everything else was flawless! :)

Canis familiaris
July 9th, 2008, 09:53 PM
My graphics card:
ATi Radeon Xpress 1250

bigken
July 9th, 2008, 09:54 PM
ati

happysmileman
July 9th, 2008, 09:57 PM
Dell Wireless adaptor for laptop, I got a Belkin one from a friend and that works OOTB.

On my Desktop, my NVidia card didn't work with 3d stuff OOTB, but that's because the drivers weren't included obviously, so I don't think that counts. The restricted drivers manager worked fine.

VitaLiNux
July 9th, 2008, 09:59 PM
ati

I know of many people who have had the same experience with Ati.

fatality_uk
July 9th, 2008, 10:02 PM
Nothing. everything worked 100%, first time.
nVidia gfx card
Hp Deskjet 970cxi printer
Creative soundblaster Audigy2
7-in-1 card reader
DVD writer x 2
24" Philips monitor

x0as
July 9th, 2008, 10:07 PM
Wouldn't even boot without changing the boot options.

terry_gardener
July 9th, 2008, 10:07 PM
creative x-fi soundcard.

all other h/w work OTB

use onboard sound because it works flawlessly and cant x-fi tok work properly with all apps that i use.

JT9161
July 9th, 2008, 10:07 PM
Atheros AR242x Wireless Card, but ndiswrapper took care of that easily.

spupy
July 9th, 2008, 10:12 PM
Toshiba Satellite. Everything works dandy right out of the box.


Except the touchpad. It works, but occasionally it would crash the whole OS. I am not sure what the problem is, but only Gentoo works ok with the touchpad. But in Gentoo it works so well, I'm not sure how windows users live with no synaptics drivers. :)

Tatty
July 9th, 2008, 10:22 PM
I assume we are mainly talking about hardy installs here...

On my laptop, the restricted drivers manager installed the latest nvidia drivers which seem to be very buggy with my Geforce Go 6100 card. But using envy to install an older driver fixed that nicely.

On my desktop, it had no clue what to do with my Nova-T 500 tv carc. However I found a nice webpage with step by step instructions on how to get that working, so all good. - In case anyone surfs in on this page looking for the same howto, it is here http://www.mythtv.org/wiki/index.php/Hauppauge_WinTV_Nova-T_500_PCI

doorknob60
July 9th, 2008, 11:24 PM
Well in Debian:
Wireless
Ati
Nvidia
(2 different cards :-P Not using both at the same time)

On a Kubuntu Live CD, everything worked out of the box, and it didn't take much configuration to get them working in Debian either.

isecore
July 9th, 2008, 11:51 PM
I guess it kind of depends on the definition, but pretty much all of my hardware worked fine out of the box on Hardy x64. Of course, some things (such as my trusty ol' Logitech MX1000) could be tweaked to better represent the functionality I desired. But I suppose everything provided at least basic functionality :)

NxZDr
July 9th, 2008, 11:55 PM
The proprietary Keyboard layout of my notebook. It has these programable launch buttons and a special Umlaut key, but the company is small and has no linux drivers. Everything else worked perfectly.

YaroMan86
July 9th, 2008, 11:57 PM
All my hardware worked out of the box with Ubuntu for me.

Can't say the same for Windows XP.

fktt
July 10th, 2008, 12:09 AM
To the question in the thread name:
everything worked, guess i got lucky with the hardware. :)

Me, happy. :3

FuturePilot
July 10th, 2008, 12:10 AM
Nothing.

XVII
July 10th, 2008, 12:12 AM
My GeForce 8500 GT.

bukwirm
July 10th, 2008, 12:36 AM
Everything worked.

Unlike my last 2 installations of Windows XP, which refused to recognize any of three different Ethernet cards.

Jim!
July 10th, 2008, 12:46 AM
Everything worked 'out of the box' with 7.10 but in the transition to 8.04 my buily in Pro Duo card reader stopped working but it didnt matter because I had a USB adapter for it already which I usually used for it anyway because most other computers dont have that specific card reader built in anyway:D Ubuntu is AWESOME!

OutOfReach
July 10th, 2008, 12:54 AM
Nothing, lol, everything worked out-of-the-box. Im one of the lucky few :popcorn: :lolflag:

dizee
July 10th, 2008, 12:58 AM
3d acceleration on my ati graphics card.

i don't really need it anyway.

wifi was automatically detected, in edgy i had to install network manager and use a static ip but since feisty it's worked great straight off.

printing doesn't work either but that's entirely my own fault for buying a crummy cheap printer from a very linux-unfriendly company, lexmark. in my defence i didn't know about linux at the time.

--just remembered another one, my volume keys on my laptop don't work ootb with xubuntu but they always did with ubuntu. but then that's not such a big deal and it's trivial to fix.

lisati
July 10th, 2008, 01:01 AM
I've stuck with 7.04 (Feisty), the main annoyances with things not working "out of the box"


Sound on my laptop (fixed by installing updates)
USB keyboard & mouse on laptop would stop working after 5 minutes or so (fix described at http://ubuntuforums.org/showthread.php?t=854684)
Playing some DVDs (fairly standard, covered by Ubuntu documentation)

steveneddy
July 10th, 2008, 01:22 AM
onboard web cam

but i already had the kernel module, so I just loaded it myself

other than that, nothing

ShodanjoDM
July 10th, 2008, 02:36 AM
PC spec:
Intel i910GL
Nvidia 7600GS
Audigy 2 ZS

Everything works OOB

Laptop:
Toshiba Satellite M200

Bluetooth and LCD brightness control weren't working directly (Phoenix BIOS). Fixed them with omnibook module from here (http://omnibook.sourceforge.net/doku.php).

deejaypip
July 10th, 2008, 02:42 AM
My mute button. My back/forward keys. Other than that, nothing :)

SuperStuff
July 10th, 2008, 02:53 AM
Thinkpad R31 volume buttons & trackpoint would jump to the corner every now & then. I switched to a USB mouse to fix that, but I think an update may have fixed that because I haven't noticed the problem tonight while using it. :KS

dracule
July 10th, 2008, 02:57 AM
just had to download Nvidia driver and wifi adapter, all recognized by the hardware driver app. :)

Very very very happy with linux w/ 7.10 and 8.04

keiichidono
July 10th, 2008, 02:08 PM
Flash didn't work properly out of the box, i had to install Flash 10 beta's to get it to work nicely.

Styled soft subs in MPlayer/SMPlayer weren't enabled out of the box, had to enable them.

Yeah, these were my only problems with Ubuntu, not very big, i know. :D

zmjjmz
July 10th, 2008, 02:10 PM
iSight
Volume control
Right click (actually, not entirely true, in Feisty I could use F12, but in Gutsy that stopped working)
That's really about it, my MacBook was well supported.

rsaavedra
July 10th, 2008, 02:14 PM
Recenty reinstalled my Ubuntu Hardy Heron (except for my /home partition) with all its updates, and my printer still doesn't work right out of the box. Printer is an HP 1020 laser, connected through USB.

This printer gets detected and recognized perfectly and quickly, but printing a document shows no error, and nothing goes to the printer, no blinking lights, nothing.

In Gutsy I remember that a workaround was to restart Ubuntu, suddenly the printing job from the previous Ubuntu session did reach the printer in this session (!). I remember reading that this was a known bug in CUPS.

Been using Ubuntu for more than a year, and this problem is still here, apparently hasn't been removed.

quinnten83
July 10th, 2008, 03:01 PM
My HP scanjet 2400 and my wacom bamboo one tablet.
The latter I could fix.

Sam Lars
October 16th, 2008, 11:13 PM
Maybe wireless? I think it works by default now. Other than that, the card reader only reads SD cards...