PDA

View Full Version : [ubuntu] [SOLVED] firestarter prevents networking -- even when stopped or uninstalled!



Paddy Landau
July 8th, 2008, 12:09 AM
I have an Ubuntu machine and a Windows Vista machine. I've used Samba to enable networking between the two machines.

However...

I've discovered, through trial-and-error, that firestarter is causing a problem.

When I reboot Ubuntu, the two computers cannot see each other.

But, if I start firestarter (System -> Administration -> Firestarter), then stop it ("Stop Firewall"), the computers can then see each other.


I have to do this every time I reboot (start firestarter, then stop firestarter).
I set firestarter not to start automatically (Preferences -> Firewall -> uncheck all options). That didn't help.
Using Synaptic Package Manager, I uninstalled firestarter ("Mark for Complete Removal"). This also didn't solve the problem: In fact, I had to reinstall firestarter so that I could start it and stop it!

Does anyone know what firestarter does to the system? I would like to uninstall firestarter and undo whatever it did, so that my Windows and Ubuntu machines can see each other.

tad1073
July 8th, 2008, 12:13 AM
try
sudo iptables -F
that will/should flush all the rules set by firestarter.

linux6994
July 8th, 2008, 12:24 AM
If you are running behind a router like Linksys or Netgear you should be safe without the file wall. Try this.
You can always install rcconf and then via the terminal window do"sudo rcconf" and deselect firestarter and it will not come up on the next boot.

cariboo
July 8th, 2008, 12:28 AM
The way to stop the default firewall is to edit /etc/ufw/ufw.conf. Use your favourite editor eg:


gksu gedit /etc/ufw/ufw.conf


# /etc/ufw/ufw.conf
#

# set to yes to start on boot
ENABLED=no

Just edit ENABLED=yes to ENABLE=no

That will stop the firewall from starting on boot up.

To stop the firewall without restarting in a terminal type:


sudo /etc/init.d/ufw stop

Jim

webofunni
July 8th, 2008, 12:39 AM
I think the problem is not with the Firestarter but the underlying IPTABLES.

https://help.ubuntu.com/community/IptablesHowTo

You can check the current IPTABLES rules by following command :


sudo iptables -L

That will list the current firewall rules. Please remove the rules which are causing the issue with samba.

Post the resulting IPTABLE rules if you need any help :-)

Paddy Landau
July 8th, 2008, 01:06 AM
Thank you all for your suggestions!


try
sudo iptables -F that will/should flush all the rules set by firestarter.

Yes, that did the job. I needed to reboot both the Ubuntu and Windows machines, and then it worked.



...
https://help.ubuntu.com/community/IptablesHowTo
...

Thanks for that link. I was wanting something like that to sort out the firewall, as firestarter didn't work for my needs. I've bookmarked the link, and I shall inspect it carefully!

bodhi.zazen
July 8th, 2008, 01:32 AM
The way to stop the default firewall is to edit /etc/ufw/ufw.conf. Use your favourite editor eg:


gksu gedit /etc/ufw/ufw.conf
# /etc/ufw/ufw.conf
#

# set to yes to start on boot
ENABLED=noJust edit ENABLED=yes to ENABLE=no

That will stop the firewall from starting on boot up.

To stop the firewall without restarting in a terminal type:


sudo /etc/init.d/ufw stopJim

LOL, that is the hard way


sudo ufw disable
bodhi@hardy:/$ sudo ufw disable
Firewall stopped and disabled on system startup

And to start :


sudo ufw enablefor additional info on ufw :

community/Uncomplicated_Firewall_ufw

https://help.ubuntu.com/8.04/serverguide/C/firewall.html

Paddy Landau
July 8th, 2008, 02:01 AM
... https://help.ubuntu.com/8.04/serverguide/C/firewall.html
Thanks for the links.

bodhi.zazen
July 8th, 2008, 02:16 AM
Thanks for the links.

NP

I find ufw is easy to learn and facilitates writing rules for iptables.

Once you get a set of tables built,


sudo iptables-save > rules

Then to restore :


sudo iptables-restore < rules

Helpful for saving / backing up your tables once they become a little complex :)

Paddy Landau
July 8th, 2008, 08:58 AM
sudo iptables-save > rules
sudo iptables-restore < rules

Cool. Thanks for that.