PDA

View Full Version : [ubuntu] [SOLVED] gtkpod issues with video



eatlotsoffruits
July 8th, 2008, 12:06 AM
Hi all,

I am currently using amarok to manage my music on my ipod but would like to load some movies on there as well. I read several threads that suggest using gtkpod to sync movies with an ipod and have downloaded it and tried to use it. The problem is that gtkpod claims that it cannot load movies without the mp4v2 library. is this a normal library that comes with gtkpod and, if not, how can i get it? Thanks!

crobinson55331
July 8th, 2008, 02:09 AM
I had teh same problem but I solved it by using gtkpod-acc instead of just gtkpod. After using Handbrake to convert dvd files or television files recorded on my computer, I can convert them to mp4 using "ipod low resolution" option in handbrake and sync with ipod using gtkpod-acc. It works like a charm.

mkokotovich
July 8th, 2008, 02:10 AM
Assuming your videos are in the correct format, you should be able to use gtkpod, but you need to install the aac version.

So do:


sudo apt-get remove gtkpod

and then


sudo apt-get install gtkpod-aac

That should do it...


[edit] oops, too slow

eatlotsoffruits
July 8th, 2008, 05:07 AM
i removed gtkpod and installed gtkpod-aac just as you wrote it above but i still get an error message when i try to add a movie file to the local folder of gtkpod. Here's the error message that appears:

Import of '/media/OneTouch 4/Movies/FightClub.mp4' failed: m4a/m4p/m4b not supported without the mp4v2 library. You must compile the gtkpod source together with the mp4v2 library.
The following track could not be processed (filetype is known but analysis failed): '/media/OneTouch 4/Movies/FightClub.mp4'

I'm pretty slow when it comes to installing or compiling pretty much anything...how do i compile gtkpod together with the mp4v2 library?

some (perhaps pertinent details):
I'm running Gutsy, I use Amarok with my ipod and, after some updates to the libraries, it's working great. I also am using an 80G ipod and already have several movies in the mp4 format.

Thanks for your advice/help!

eatlotsoffruits
July 9th, 2008, 01:54 PM
So can anyone tell me how to get that library? Or suggest something other than gtkpod that i can use for ipod video?

mkokotovich
July 14th, 2008, 04:58 PM
Sorry for the delay

I believe that Gutsy's version of gtkpod didn't work for me when I was trying to add movies.

If you don't mind the hassle of upgrading to Hardy, I would go for it, and I bet it'll fix your issues. That would be the easiest way to get things to work. There are other ways, but they seem harder right now.

eatlotsoffruits
July 15th, 2008, 04:24 PM
no problem about the delay. In fact, thanks for replying at all! I'll give upgrading to Hardy a shot and report back on how it went.

mkokotovich
July 16th, 2008, 12:13 AM
Sounds good. Just remember to install gtkpod-aac, and that should do it. If it isn't working... well let's just hope it works :-P

eatlotsoffruits
July 16th, 2008, 02:45 PM
I upgraded to Hardy last night and installed gtkpod-aac....it worked like a charm! Thanks so much for your help!

mkokotovich
July 18th, 2008, 03:59 AM
You're welcome, I'm glad it worked!