PDA

View Full Version : [ubuntu] Nvidia AGAIN! I don't know why I always have problem with it!



incen
July 7th, 2008, 10:35 PM
After updating my Ubuntu Hardy last week, I came to office this morning and turned on my computer. AGAIN! I lost the resolution of my monitor again! I tried to recover it with the lately backed-up xorg.conf but it didn't work!!! That was sooooo weird! So I redo all the stuff again...
sudo aptitude install nvidia-glx-new
sudo aptitude install nvidia-settings
and then did
sudo nvidia-xconfig

but the generated xorg.conf file couldn't even improve the problem at all

Finally, I did as what i usually do:
Following what PmDematagoda said in http://ubuntuforums.org/showthread.php?t=692827
And then... this is what I have:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection
Isn't this weird??? There are no parameters!!!

chrisccoulson
July 7th, 2008, 10:51 PM
Thats normal.

To use the proprietary NVIDIA driver, you need to add the following line to the Device section of your xorg.conf:

Driver "nvidia"

Then try to restart your X server with this configuration. If you're still having problems with the resolution, then you might want to consider attaching your /var/log/Xorg.0.log file

ellgor
July 8th, 2008, 05:22 PM
Hi,

Try this, check to see if you have a package called nvidia-settings (in synaptic) install it if not, open a terminal and type in "gksudo nvidia-settings" (without the quotes) this will open a new window with the nvidia settings for you to play with, adjust as needed, hope this is of help.

Regards, Ellgor.

arloth
July 8th, 2008, 05:31 PM
I've had a few issues with my monitor resolution in the past with nvidia cards. Usually what messed it up for me was having the monitor off when the computer was starting up. Make sure the monitor is on before you turn the computer on so the video card can pickup the EDID info and hopefully pick a more sane resolution for you. :)

Joshuwa
July 8th, 2008, 05:46 PM
This seems related to the problem of the pre-existing drivers, and Ubuntu falling back on them, ignoring the newly installed ones.

After downloading the NVidia driver from NVidia's website, run these commands in the same directory that you downloaded the driver to:

sudo apt-get install linux-headers-`uname -r` build-essential gcc gcc-3.4 xserver-xorg-dev
sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common
sudo rm /etc/init.d/nvidia-*
sudo /etc/init.d/gdm stop
sudo sh NVIDIA-*
sudo nvidia-xconfig --add-argb-glx-visuals
sudo /etc/init.d/gdm start

incen
July 8th, 2008, 08:02 PM
Hi,

Try this, check to see if you have a package called nvidia-settings (in synaptic) install it if not, open a terminal and type in "gksudo nvidia-settings" (without the quotes) this will open a new window with the nvidia settings for you to play with, adjust as needed, hope this is of help.

Regards, Ellgor.

Yes, I do have it installed. However, when I did "gksudo nvidia-settings", this is the error message:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server

incen
July 15th, 2008, 04:21 PM
This seems related to the problem of the pre-existing drivers, and Ubuntu falling back on them, ignoring the newly installed ones.

After downloading the NVidia driver from NVidia's website, run these commands in the same directory that you downloaded the driver to:

sudo apt-get install linux-headers-`uname -r` build-essential gcc gcc-3.4 xserver-xorg-dev
sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common
sudo rm /etc/init.d/nvidia-*
sudo /etc/init.d/gdm stop
sudo sh NVIDIA-*
sudo nvidia-xconfig --add-argb-glx-visuals
sudo /etc/init.d/gdm start

Hi, when I do this, it just shows like this:

:~$ sudo /etc/init.d/gdm stop
* Stopping GNOME Display Manager... [ OK ]

without really killing my X-server. Could anyone tell me what is wrong with my video card or driver? Now I even cannot have my screensaver working all right. :(


I re-install nvidia-glx-new again by doing:


sudo aptitude remove nvidia-glx-new
sudo aptitude install nvidia-glx-new nvidia-settings
but I still cannot kill my X-server.

Canis familiaris
July 15th, 2008, 04:24 PM
To kill X:
Ctrl + Alt + F1

sudo killall gdm

incen
July 15th, 2008, 04:33 PM
OK. Now I re-sh the latest NVIDIA driver again and finally I get the looked-right xorg.conf. Also, the little Hardy feature of moving between desktops is coming back!!!
However, there are some weird things happening when I kill the X-server and install the latest driver.

Unable to create '/usr/lib/nvidia/libglx.so.xserver-xorg-core' for coping (No such file or directory)
and another one.
What does it mean? Should I create such a directory for it?