PDA

View Full Version : [ubuntu] [SOLVED] How to enable Nvidia sli



MantinoX
July 4th, 2008, 12:39 AM
IM a total noob about this an i need help. My nvidia x server detects both card but its only reading one. Both are working but only one is doing the job.
How do i get into the x server?

chuck@chuck-desktop:~$ nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.


ERROR: Unable to write to directory '/etc/X11'.

chuck@chuck-desktop:~$ sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

chuck@chuck-desktop:~$

MantinoX
July 4th, 2008, 12:51 AM
when i get into the config file


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Enlitend
July 4th, 2008, 01:20 AM
Hi,

To enable SLI:

sudo nvidia-xconf --sli=On

The valid values for SLI are "Off", "On", "Auto", "AFR", "SFR", "AA", and "AFRofAA".

Try

nvidia-xconf --advanced-help

for a complete list of option that you can configure, just be sure to know what you are doing:)
Hope this help.

MantinoX
July 4th, 2008, 01:49 AM
chuck@chuck-desktop:~$ sudo nvidia-xconf --sli=On
[sudo] password for chuck:
sudo: nvidia-xconf: command not found
chuck@chuck-desktop:~$ nvidia-xconf --advanced-help
bash: nvidia-xconf: command not found
chuck@chuck-desktop:~$ sudo nvidia-xconf --advanced-help
sudo: nvidia-xconf: command not found
chuck@chuck-desktop:~$



What did i do wrong my friend... Any ideas why?

MantinoX
July 4th, 2008, 01:55 AM
Hi,

To enable SLI:

sudo nvidia-xconf --sli=On

The valid values for SLI are "Off", "On", "Auto", "AFR", "SFR", "AA", and "AFRofAA".

Try

nvidia-xconf --advanced-help

for a complete list of option that you can configure, just be sure to know what you are doing:)
Hope this help.

K i know what i did wrong had to spell config out. so it should be

sudo nvidia-xconfig --sli=On