PDA

View Full Version : No reconoce teclado al inicio



mab57
July 2nd, 2008, 05:29 AM
Hola, tengo instalado UBUNTU 7.10 con todas las actualizaciones.
El problema es que al iniciar la máquina NO reconoce el teclado y si el mouse. Para lograr que lo reconozca, al momento del boot (luego de hacer el conteo para entrar en modo seguro) debo presionar la tecla "Num Lock" y luego cambiar de una sesion a otra, hasta que lo reconoce. Una vez hecho esto, el teclado funciona bien en todo momento.
He probado cambiar el tipo de teclado "PC generico 101 teclas" o "PC generico 105 teclas (intl)", pero sigue igual.

Alguna idea de qual puede ser el problema?
Gracias de antemano...
:) Miguel

Mauro22
July 2nd, 2008, 02:45 PM
postea tu xorg.conf


cat /etc/X11/xorg.con

mab57
July 3rd, 2008, 12:44 AM
Aqui va el xorg.conf:

miguel@mab:~$ cat /etc/X11/xorg.conf
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Boardname "nv"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Option "NoLogo" "True"
Option "AllowGLXWithComposite" "True"
EndSection

Section "Monitor"
Identifier "S/M 550v"
Vendorname "Samsung"
Modelname "Samsung SyncMaster 550v"
Horizsync 30-55
Vertrefresh 50-120
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Monitor "S/M 550v"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "1024x768@60" "1024x768@43" "832x624@75" "800x600@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "ServerFlags"
EndSection


:) Miguel

Mauro22
July 3rd, 2008, 12:51 AM
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection




Yo no tengo esa opcion, si queres hace una copia de ese archivo y comenta ( # ) esa opcion. Por ahi es eso. Lo demas lo tengo igual


PD: Probaste con otro teclado?

mab57
July 4th, 2008, 01:13 AM
Gracias Mauro22.

Ya había probado con otro teclado, y hacía lo mismo.
Pero ahora comente la linea Option "CoreKeyboard" y esta funcionando bien.

(P.D.; no supe como marcar este threads como resuelto)
:-) Miguel