PDA

View Full Version : [ubuntu] cant move file to trash in mounted disks



cotiK
June 27th, 2008, 01:52 PM
I surpssngly found out that i cant move files to trash (i can only permanently delete them) in my exteranl ntfs usb disk, and 2 partitions of the same sate drive where my filesystem is in. (one fat, one ntfs).
i cant think of anything i did that explains this. in the past i could move files to trash in these drives

kaibob
June 27th, 2008, 02:21 PM
I surpssngly found out that i cant move files to trash (i can only permanently delete them) in my exteranl ntfs usb disk, and 2 partitions of the same sate drive where my filesystem is in. (one fat, one ntfs).
i cant think of anything i did that explains this. in the past i could move files to trash in these drives

I enabled the trash function for ntfs and vfat partitions that are mounted by fstab as follows:

1) Backup fstab.

2) Add uid=1000,gid=1000 as options to the partition's fstab entry (see example below).

3) Create a directory named .Trash-1000 in the partition's root.

4) Restart the computer.

Upon completion of the above, deleted files will be placed in a directory named files within the .Trash-1000 directory, and your Ubuntu desktop trash icon will show the deleted files. The panel trash icon does not seem to reliably show the deleted files.

~~~

Example fstab entry
UUID=44B5-9621 /media/store vfat defaults,utf8,umask=007,uid=1000,gid=1000 0 1

Bliepo32
June 27th, 2008, 02:46 PM
It can also be that your disks are mounted as readonly.

cotiK
June 27th, 2008, 02:48 PM
Upon completion of the above, deleted files will be placed in a directory named files within the .Trash-1000 directory, and your Ubuntu desktop trash icon will show the deleted files. The panel trash icon does not seem to reliably show the deleted files.

in the past when i deleted a file from these drives it went to a ".trash" hidden folder in that disk. I want that enabled.

cotiK
June 27th, 2008, 03:35 PM
It can also be that your disks are mounted as readonly.
ι can write files to them

kaibob
June 27th, 2008, 05:17 PM
in the past when i deleted a file from these drives it went to a ".trash" hidden folder in that disk. I want that enabled.

cotiK,

I researched this issue back when Hardy was still in beta, and the workaround detailed in my above post worked for me. I didn't care if the hidden file was named .Trash or .Trash-1000.

There was a bug report on this issue, and it may now have a fix that will allow you to do what you want. I don't have a link, but a Google search may lead you to it. Or, perhaps someone else has something that will help you.

kaibob

cotiK
June 28th, 2008, 12:01 AM
cotiK,

I researched this issue back when Hardy was still in beta, and the workaround detailed in my above post worked for me. I didn't care if the hidden file was named .Trash or .Trash-1000.

There was a bug report on this issue, and it may now have a fix that will allow you to do what you want. I don't have a link, but a Google search may lead you to it. Or, perhaps someone else has something that will help you.

kaibob

ooohh, so you mean this is a "feature", not a bug?
i just thought that i broke sth. Also the trash-1000 folder you suggest i thaught would appear in my filesystem partition and not the other partitions. (like deleting a file from my usb drive and apearing in trash in my filesystem partiion

anyway, thanks alot!

kaibob
June 28th, 2008, 12:11 AM
ooohh, so you mean this is a "feature", not a bug?
i just thought that i broke sth. Also the trash-1000 folder you suggest i thaught would appear in my filesystem partition and not the other partitions. (like deleting a file from my usb drive and apearing in trash in my filesystem partiion

anyway, thanks alot!

No, it's a bug (at least as far as I'm concerned).

The trash-1000 folder is in the NTFS or FAT partition.