PDA

View Full Version : [ubuntu] I killed samba



imnotatfault
June 27th, 2008, 02:56 AM
I am running Hardy Heron 8.04 Desktop and all was fine until today. On my home network is a PC and a Mac. I was able to access shared files both ways, was running torrentflux and firefly from the linux box, and samba and i were generally friends (although, in hindsight, i should have maybe gotten him a card letting him know how much i appreciated what he did behind the scenes)

i did a fair amount of tinkering today. torrentflux wasn't handling my usenet server b/c it doesn't requires a u/n or pass, so i installed zussaweb. but before then, i tried both hellaworld and hellahella unsuccessfully. somewhere, along the way, something i did upset the almighty samba.

i can no longer connect to any computers from linux nor can they connect to the linux box. when i open network locations in nautilus, the computer hangs for a few seconds before giving me the error "no application is registered as handling this file." torrentflux web gui is up and i can access it from linux box only (error from other computers) nor can i even ssh into it from the pc using putty. i inserted my ubuntu live cd and upon booting from there, all network locations were available and accessible immediately.

i have already tried uninstalling/reinstalling every samba related package i could find in synaptic (to no avail). i'm really hoping there's a simple fix. it's going to be a pain to repartition my drive to do a fresh install, get all of the apps back and configured, and to salvage my hundreds of gigs of media i already have on here. any help would be greatly appreciated. thanks!