PDA

View Full Version : [ubuntu] VERY slow wireless connection in ubuntu



ShaiI769
June 26th, 2008, 11:08 PM
Hi everyone,
I'm having a Lenovo laptop with a AG4965, with a very slow wireless connection. When i'm using an ethernet cable it's fine, but when I switch to wi-fi, the speed differences between vista and ubuntu (I dual boot), are huge (~1000 kbps in vista, ~150kbps in ubuntu, download speed. I used speedtest.net).

The problem is not only in firefox (I pinged google and it took ubuntu 237 ms to deliver a 64 bytes packet, also the speed in synaptic and pidgin are slow as in dial up).

I tried disabling IPV6, but no luck. The wireless connection is still VERY slow. As said, in vista the speed is fine.

I would really appreciate any helpful idea, this is truly frustrating

Thanks in advance.

ShaiI769
June 28th, 2008, 04:46 PM
Anyone? I would be happy to solve this one. Thanks. :)

Fury5000
June 28th, 2008, 05:43 PM
It might be that your windows driver is fully recognizing and supporting your wireless card and Ubuntu isnt and is using some universal driver that is dropping you down to 10BaseT and not 100BaseT... just guessing tho.

I did notice the other day that when booting from XP vs Ubuntu and going to Speedtest.net and checking the data transfer speeds it was higher in XP for some reason. I dont know enough about it to know why this is. I also get different signal strength numbers in each but I dont know what OS is telling me a more accurate strength number. Its something for the Linux heads to explain.