View Full Version : [ubuntu] network-admin gone AWOL

June 26th, 2008, 10:00 PM
Hardy 8.04, network-admin has gone bye byes, even the applet has disappeared from the system tray. Everything seems to be working ok as far as internet and local networking, apart from browsing shares on windows machines but that never worked anyway. I can enter smb://IP.ad.re.ss/sharename to access my shares bit of a bugger if you can't remember the share name but it worked at least. But methinks something more serious has happened. System>Administration>Network brings up an error Could not launch menu item, Failed to execute child process "network-admin" (No such file or directory) and that's that. Checked the interfaces file and got

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

ifconfig yields

eth0 Link encap:Ethernet HWaddr 00:e0:4d:3b:ce:1e
inet addr: Bcast: Mask:
inet6 addr: fe80::2e0:4dff:fe3b:ce1e/64 Scope:Link
RX packets:57788 errors:0 dropped:0 overruns:0 frame:0
TX packets:59115 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:47548266 (45.3 MB) TX bytes:32038743 (30.5 MB)
Interrupt:247 Base address:0x8000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:3164 errors:0 dropped:0 overruns:0 frame:0
TX packets:3164 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:160962 (157.1 KB) TX bytes:160962 (157.1 KB)

any help would be appreciated.

June 27th, 2008, 04:47 PM
Nobody got any ideas on how to return network-admin apart from a reinstall?

June 27th, 2008, 08:21 PM
network-admin has gone bye byes, even the applet has disappeared from the system tray.

You can try bringing back the applet by opening a terminal and giving the command
nm-applet If it doesn't work, the error output might be useful for diagnosis.

If it works, note that it will close down when you close the terminal. In that case, press Alt+F2, and give the same command. It should reappear, and it should be persistent across reboots, otherwise you may have to add it to System-Preferences-Sessions-Startup Programs.

June 28th, 2008, 11:24 AM
Thanks for the reply, unfortunately twas one of the first things I tried, problem solved by reinstall, drastic but other stuff was misbehaving too.

December 16th, 2009, 06:27 AM
In trying to change my DNS, I just noticed my network-admin has mysteriously disappeared in 9.10; "System > Administration" had only "Network Tools" and no "Network" option. I thought maybe they'd moved network configuration somewhere else but couldn't find it anywhere, or any information on the web except this forum. I eventually just installed gnome-network-admin from synaptic, and now it shows up in the system > admin menu. What the?!