View Full Version : [ubuntu] university wireless network does not have support/help info for Linux

June 24th, 2008, 04:55 PM
ok, my wife and i have recently moved our laptops to Linux (Ubuntu 8.04) and are really loving it. however, it appears that our school (East Tennessee State University, in the US, for those interested) does not have support pages for setting up Linux on their wireless networks. i have emailed OIT (our IT department, mostly staffed by Computer Science majors) and gotten the following email:

I am sorry but there is no configuration available for the Ubuntu OS
currently and I do not see any plan in the near future for ETSU wireless to
become compatible.

now, i don't know if this is something inherently incompatible between Linux and the wireless networks, or if OIT are just a bunch of helpless M$ monkeys who just don't know what they are doing. the whole CS department is funded by M$ (tons of free software for an assurance of only supporting their products) so i wouldn't put this past them.

anyway, long story short, here are the directions for configuring XP to work on their network. http://www.etsu.edu/oit/wireless/ if anyone has any ideas, i'd appriciate it, cause while i know a bit about programming, the net has always been a weak spot in my knowledge, and i'm new to Linux, so i'm not sure where to really get started. thanks!

June 24th, 2008, 05:01 PM
If you click on the network-applet and select connect to other wireless networks you are presented with a drop down menu.

Select WPA Enterprise and you should be able to change the relevant configs.

Post back if this works.

June 24th, 2008, 06:44 PM
no luck. however, i think this may be close, as i got something resembling the Windows login dialog for the network. however, i played around with it for about a half hour before giving up and coming home to a do other things.

thank you for your input and help. i'll likely play with these settings some more tomorrow and see if i have any luck.

June 24th, 2008, 07:30 PM
they're using 802.1x, and you're going to need that certificate they have for the handhelds. i've setup wireless networks for windows utilizing 802.1x with certs, but i haen't done it with linux clients. you'll have to do a search on how to use that cert. do not try wpa or wep. you may want to check out this link (http://en.wikipedia.org/wiki/Xsupplicant) for a supplicant that may work from the open1x project.

also, if you're paying to go to school there, you should be able to go to the administrative staff (not the IT department) and raise a big ruckus, because you're the customer, and they need to make the network you paid for accessible to you. but that will take time.

June 25th, 2008, 03:24 PM
thank you. i shall definitely give this a try when i get a chance! looks like it may solve all our issues. i'll post back if anything comes of this. thanks!

June 25th, 2008, 07:07 PM
it took me many hours to get villanova university's wireless working on ubuntu, and that was on breezy i think, i haven't had to use it on hardy at all...

but from what i remember, i had to use xsupplicant via the terminal, and had it point to some hacked certificates and config files with my username and password and stuff. i will see what i can do to find my old config files and stuff.

edit: here is the contents of my old config file

#network_list = default, test1, test2
network_list = Villanova

#default_netname = my_defaults
default_netname = Villanova

logfile = /var/log/xsupplicant.log

Villanova {
allow_types = eap-ttls

identity = <BEGIN_ID>anonymous<END_ID>

eap-ttls {
root_cert = /etc/xsupplicant/Equifax.cer
# chunk_size = 1398
# random_file = /dev/urandom
#cncheck = ns2.villanova.edu
#cnexact = no
phase2_type = pap

pap {
password = <BEGIN_PASS><END_PASS>

its relatively obvious where your stuff would go, but obviously i can't tell you what the name of your specific certificate would be, or where do even really find it within windows. you might be able to talk to tech support to figure out what the settings for that config file would be.

remember that most linux kids are willing to help out other users..when i was doing this at my school, there were a couple of IT guys who used linux, and were interested in helping me figure it out, so you might want to poke around in IT and see if there is anyone else in the same boat.

June 25th, 2008, 07:22 PM
that would be amazing. thank you.

June 25th, 2008, 07:27 PM
there may or not be a better way to do all of this now also. xsupplicant still does exist, but there may be gui-fied options for configuring that text file.

June 25th, 2008, 11:44 PM
Have you tried connecting using a LEAP configuration? Just been looking at the tutorials they give and thats how they do it with the MACs.

September 5th, 2008, 05:48 PM
ok, thanks Sub101, although i didn't see your post before i figured it out myself, this is indeed exactly the solution, at least on Intrepid alpha 4 (my laptop). i won't know if this works with Hardy until i try to get my wife's laptop online on Monday.

September 5th, 2008, 05:56 PM


might help

September 9th, 2008, 03:41 AM
LEAP seems to work on Intrepid Alpha...5 i think is what is on my laptop... but it seems that Hardy doesn't seem to like it.

it was so easy on Intrepid, i just selected LEAP, input my user name and password, and BAM... no such luck on my wife's Hardy machine... although its been acting a little odd for the last few days anyway, so it may be unrelated.

October 30th, 2008, 05:50 AM
My name is John, I'm a freshman at ETSU this year. I recently installed Ubuntu 8.10 on my laptop, and I also can't access our wireless connection. I've been leeching off my neighbor's router so far, but that doesn't work in class. I don't have too much Linux experience, and I'm pretty sure I can't get this working. Please update this thread if you do manage to get connected. Thanks.

October 30th, 2008, 03:20 PM
on Intrepid select LEAP when it asks for the type of encryption on the network, input your user name (it used to be a zName, i.e zABC01, but i think it may have been changed recently, i mean whatever you use to log into the campus labs) and password and you should get connected. be advised however, that currently my laptop and my wife's laptop have had a regression in Intrepid in the wireless networking, and neither are able to connect to any wireless network. if you are able to connect to other networks, you should have no problems though.

welcome to ETSU and Intrepid!

October 30th, 2008, 10:47 PM
I actually tried that before I came to this forum for help. It wants a config type file I believe. I'm not on campus until Saturday, but I'll try again when I get back and see what I can do.

October 31st, 2008, 09:46 PM
my wife and i neither one have had to provide any type of config file, which is odd. another ETSU student who frequents these boards was also having trouble w/ LEAP, so i'm not sure what is up with that.

November 2nd, 2008, 11:57 PM
Sorry, I meant a certificate, not a config file. I tried LEAP and it didn't work either.

November 3rd, 2008, 03:19 AM
yea, thats what i meant too.

strange that you are having trouble with it. do you have WPA supplicant installed? we both have it installed (i think it was installed by default, cause i do not remember ever installing it on either computer) and i know that it deals with wi-fi encryption.

January 21st, 2009, 08:05 PM
Just a small update:

I'm now running 9.04 Jaunty Alpha 3. I connected to the ETSU wireless using LEAP. I'm getting a very faint signal in the 5th floor of the communications building, but at least it's working.

April 1st, 2009, 09:04 PM
I am at ETSU as well and recently bought a dell mini with Ubuntu 8.04. I've not been able to get the wireless working either. Any help would be nice.