PDA

View Full Version : [all variants] SSH Over Internet Fails



Raptor45
June 24th, 2008, 06:56 AM
I've got ssh working over the local network, but if I try to connect over the internet it fails. The router DMZ is set to the server computer.

Any ideas?

wormser
June 24th, 2008, 07:47 AM
Directions to port forward your router should be here: http://portforward.com/routers.htm

Raptor45
June 24th, 2008, 08:09 AM
As I said, I set up the DMZ.

wormser
June 24th, 2008, 08:15 AM
I am no networking expert, but you should use port forwarding and not DMZ. Read this (http://www.homenethelp.com/web/explain/port-forwarding-dmz.asp). One thing you can do is use nmap to see if the port is open.

ujwols
June 24th, 2008, 08:22 AM
Can you explain in detail what all steps that you followed ?
Starting from obtaining host services .. You might be missing some step. And also can you explain your hardware setup like how many level of router do you have because for my case i have an ADSL router which is connected to wireless router and the wireless router in turn is connected to my PC.. So in my case I have two level routers is it the same for you ???

shad0w_walker
June 24th, 2008, 08:25 AM
Can you post an error or the details of what happens when you try to connect over the internet? It fails is a little vague.

ujwols
June 24th, 2008, 08:25 AM
Btw.. DMZ would do ..Port forwarding is not Mandator..But Port Forwarding is obviously a better choice because of security reasons.

Raptor45
June 24th, 2008, 05:52 PM
I did not intend to leave the DMZ on permanently, just used it to eliminate that as a source of error.

Got a pretty basic setup, just cable modem and wireless linksys router.

By fails I mean times out.

I was originally trying to set up a remote desktop connection. I had it working about a year ago, but when I tried to set it up again it could also only connect locally. I then tried to do an ssh connection, which also won't connect.

To connect I've just been using my public IP on port 22, although I've also tried with setting ssh to a different port. It only ever works locally.

Raptor45
June 24th, 2008, 06:04 PM
Solved the problem on my own.

I have a Linksys WRT54G, and it was blocking the connection.

To fix I had to disable "Filter Internet NAT Redirection" under "Security">"Firewall".