View Full Version : [ubuntu] internet failed on hardy network

June 24th, 2008, 05:29 AM
recently upgraded all five pcs s at my office to hardy. liked the look and feel of it and all started working fine. two days back one of the pcs ( the only dual boot pc) was run on windowsxp. since then no pc on the network is connecting to internet. the wired network has pcs connected through switches and a pppoe broadband modem is connected to one of the switches. all pcs are detected from all other terminals and can be pinged. modem is and even that can be pinged and is the primary DNS server on all pcs. can anybody help me in this? any further info i'd b glad to furnish. thanks in advance.

June 24th, 2008, 07:54 AM
Sound like you are getting IP address and you can ping on the local internet. Have you tried pinging over the internet by domain and IP address?

ping ubuntuforums.org


If you can ping by IP and not by domain then it is a DNS issue. Open DSN (https://www.opendns.com/start/ubuntu.php) should fix that. Another thing to try is unplug your router for 10 seconds.

June 24th, 2008, 10:21 AM
thanks, 'll try that and get back. i m away from my workplace rt now.

June 24th, 2008, 08:25 PM
thanks a lot - changing to open DNS solved the problem but everytime i reboot the DNS needs to be changed. i added DNS by editing the DNS tab of networkfrom system>administration>. how do i change the DNS settings permanantly?

June 24th, 2008, 09:39 PM
Permanent settings directions are at the bottom of that link.

To avoid having your settings get revoked after reboots, or after periods of inactivity, do this:
$ sudo cp /etc/resolv.conf /etc/resolv.conf.auto
$ sudo gedit /etc/dhcp3/dhclient.conf
# append the following line to the document
prepend domain-name-servers,;
# save and exit
$ sudo ifdown eth0 && sudo ifup eth0 You may be required to change eth0 to your own network device's name if it uses a non-standard name.