PDA

View Full Version : [ubuntu] Sound stopped working



EmilyRose
June 22nd, 2008, 03:31 PM
My sound has mysteriously stopped working - first noted trying to watch youtube videos, but it doesn't work in anything now (tried sound prefernces tests and don't hear a thing). My speakers are turned all the way up, and I checked all the volume controls are turned all the way up, too.

walkeraj
June 22nd, 2008, 05:51 PM
Right click on the speaker icon and go to "open volume control". This should display the gui equivalent of "alsamixer". Does anything look amiss?

Pethegreat
June 22nd, 2008, 06:11 PM
I had a similar problem. It happens every 4th boot. I boot 3 times with full sound. I boot the 4th time, no sound.

I have a Pangolin Value that I purached in march 2008. I currently am running 8.04(upgraded from 7.10) with all updates.

pauper
June 23rd, 2008, 12:14 PM
I could be completely off track, but a few days back there was a kernel update. Try to restore your system configuration via:

System-Administration-System76 Driver-Restore System-Restore

EmilyRose
June 23rd, 2008, 03:17 PM
Hmm, this is wierd, sometimes when I reset it fixes it, sometimes not. The first time I load youtube, I *usually* have sound, but then after I try to do another video it won't work... so I have one shot to pick the video I want to watch, then if I want to watch another, I have to reset...

thomasaaron
June 23rd, 2008, 04:14 PM
Just tested that here, and I'm not getting those symptoms.
Are you using Hardy, Firefox, and flashplugin-nonfree?

fiartruck0125
June 23rd, 2008, 05:54 PM
My sound stopped working too.

There used to be about 6 sliders in the volume control now its down to just "pcm" and "master" both of which are up all the way and unmuted with no sound. (I checked Edit->Preferences thats all the controls available)

I tried OSS but there there's only *one* slider and it still doesn't work.

I did just do an update, but not a kernel update or anything related to sound, I don't think.

--Thomas Dunlap

thomasaaron
June 23rd, 2008, 08:34 PM
firetruck,

Run your System76 driver (System > Administration > System76 Driver).
Then reboot your computer.

thinkmassive
July 29th, 2008, 06:59 AM
I had a similar issue where my sound just suddenly stopped working when I paused a quicktime movie. I tried restarting X, which somehow made Xfce unable to manage my desktop anymore. Then I rebooted and that allowed my desktop to work again but the sound was still off.

All volume controls were on, and the media players indicated that clips were playing. Finally I pressed one of the volume buttons on my ThinkPad and it started working again.
http://ph.ubuntuforums.com/images/smilies/smiley-faces-75.gif
Haha, laugh all you want... I didn't touch the mute button, but somehow it got enabled. Just a thought.

thomasaaron
July 29th, 2008, 03:52 PM
fiartruck,

If you double-click your speaker icon and (in the resulting window) go to edit > preferences and select all of the checkboxes, you should then have more sliders.

adam.smith
August 4th, 2008, 06:18 PM
I had a similar issue where my sound just suddenly stopped working when I paused a quicktime movie. I tried restarting X, which somehow made Xfce unable to manage my desktop anymore. Then I rebooted and that allowed my desktop to work again but the sound was still off.

All volume controls were on, and the media players indicated that clips were playing. Finally I pressed one of the volume buttons on my ThinkPad and it started working again.
http://ph.ubuntuforums.com/images/smilies/smiley-faces-75.gif
Haha, laugh all you want... I didn't touch the mute button, but somehow it got enabled. Just a thought.
I'm not laughing - after spending 2h debugging my system, reinstalling alsa etc. etc. I just found your post and it saved my day. Exact same issue, also on a thinkpad - might actually be a bug.

mark q
August 6th, 2008, 11:33 PM
Yes, as another Thinkpad user I too have had this issue. It may have originated with an application, in my case this was while using Audacious. However, I feel it may stem from a conflict between the keyboard sound control and that of the desktop control. The sound was effectively muted without the speaker icon or other displays showing it to be the case. Even now muting with the keyboard does not effect the status of the speaker icon, the sound however does mute. This was discovered after a reinstallation of the alsa drivers. Just another quirk or something deeper?

timz84
August 25th, 2008, 05:05 AM
I had the same problem, using firefox and then no sound in videos or mp3s. This seemed to work for me: I did "sudo /etc/init.d/alsa-utils restart" and then closed and restarted firefox, sound works now.

dzisler
August 30th, 2008, 01:29 PM
I have just updated as of Aug 29 and now have no sound for youtube sites but have sound when playing back CD's or any stored music file. I have no opening or exit sounds and all the minimize (-) or maximize (+) or close icons that should appear in the open windows on the upper right corner are gone.

thomasaaron
September 1st, 2008, 02:21 PM
Try running these commands:

sudo apt-get remove flashplugin-nonfree
sudo apt-get install flashplugin-nonfree

Armaron
September 15th, 2008, 09:56 PM
Got the same issue. I use amaroK in the Gnome environment and after I paused the music and wanted it to continue playing, it just gave no sound.

I restarted my alsa-utils, I restarted amaroK, all the volume controls of my sound are turned up and System > Preferences > Sounds is all set on autodetect.

thomasaaron
September 15th, 2008, 11:21 PM
Amaron,

Which System76 model do you have? Did you run the System76 driver and reboot?

Emily's problem has been solved. It was a program for running a modem that conflicted with ALSA.

Armaron
September 15th, 2008, 11:58 PM
Amaron,

Which System76 model do you have? Did you run the System76 driver and reboot?

Emily's problem has been solved. It was a program for running a modem that conflicted with ALSA.

I don't know what a System76 model is or where I could check the driver.

benjo316
September 16th, 2008, 12:24 AM
I don't know what a System76 model is or where I could check the driver.http://system76.com/

^
|
"System76 Support"

Are you using a system76 Laptop or Desktop?

thomasaaron
September 16th, 2008, 03:34 PM
This forum is for the support of System76 computers. Did you purchase your computer from System76?

If you did, you can go to System > Administration > System76 Driver and see your model number. In fact, while you are there, click on the Install Tab and Install Button to fix your sound, and then reboot your computer for the drivers to take effect.

If you do not have a System76 computer, we might still be able to point you in the right direction, but we don't have non-System76 computer models in our shop to test with.

phyzome
September 18th, 2008, 06:37 PM
Run your System76 driver (System > Administration > System76 Driver).
Then reboot your computer.

Even simpler: Spit over your left shoulder, turn clockwise three times, and reboot. It works for me... because rebooting solves the problem (temporarily) by itself. :-/

What is needed is a solid test-case that will cause the "muting". Then this sequence can be followed:

Execute proposed solution
Reboot
Run test-case
Check if "muting" has occurred


(This is not to say installing the System76 driver should not be the first step. I'm just noting that it might appear to "fix" the problem for some people temporarily, even though it's not the actual solution.)

phyzome
September 18th, 2008, 10:13 PM
I've tried the following suggestions (in roughly this order):


Check alsamixer settings
Check Preferences -> Sound settings (Autodetect x 3 and PulseAudio)
killall pulseaudio
sudo /etc/init.d/alsa-utils restart
Uninstall and reinstall flashplugin-nonfree
Install System76 driver
Reboot


To test these as a group, I have done the following:

Play a YouTube video
Play music in Rhythmbox
Some combination of these in sequence
Some combination of these in parallel


The test case I have worked out that will cause the muting (at least on my panp4i):

Suspend and close laptop
Open laptop (un-suspends)


I believe that rebooting after a suspend clears the problem.

I do not think that any of the suggestions I have tried so far have worked as well as a reboot.

thomasaaron
September 19th, 2008, 03:22 PM
Pyhzome,

This thread had been hijacked pretty badly. The original problem, posted by Emily has long been solved. It was a modem program she installed that caused ALSA to fail. So uninstalling the program fixed her computer.

The problem you are describing sounds to me like it might be this...
https://bugs.launchpad.net/system76/+bug/264516

smaddox
June 12th, 2010, 07:03 PM
My sound stopped working too.

There used to be about 6 sliders in the volume control now its down to just "pcm" and "master" both of which are up all the way and unmuted with no sound. (I checked Edit->Preferences thats all the controls available)

I tried OSS but there there's only *one* slider and it still doesn't work.

I did just do an update, but not a kernel update or anything related to sound, I don't think.

--Thomas Dunlap

Thanks for the tip. This worked for me. Sound stopped working randomly, but just cycling the mute button on my logitech keyboard got the sound working again. Note that before cycling the mute button, none of the indicators showed muted.