View Full Version : [xubuntu] Cant Setup HP all-in-one over network

June 21st, 2008, 10:20 PM
Hello, just got a new all-in-one today and would like to set it up on xubuntu. Its a HP Photosmart C5280 All-in-One (http://h10010.www1.hp.com/wwpc/uk/en/ho/WF05a/5043-5527-7369133-7369133-12721008-80135111.html), connected to Windows XP which I can access the shared folder.

I've tried using hijips or whatever its called but it doesnt find the printer. When I use the Applications > Settings > Printer > Add New Printer, it finds it but cant install it because I cant select the correct printer for the list of ones available.

I dont have a clue what to do, please help :)

June 22nd, 2008, 02:28 AM
Did you try hplip? Or is that what you were alluding to? Using HPLIP, I set up an HP7580 and it seemed to work perfectly. I can print, double sided print, and scan without problems. I haven't tried faxing but it certainly looks like it is set up to go.

PS: I'm mostly a newbie, so any advice I give is probably worthless!!!!!


June 23rd, 2008, 05:08 PM
Yep thats what I ment HPLIP, it doesnt seem to detects the printer :( yet xubuntu's printer tool does but doesnt have the required driver.