PDA

View Full Version : [ubuntu] Can't login



Abu_Dayya
June 21st, 2008, 08:28 AM
I installed language support for arabic language yesterday. And when the onstallation was complete the OS prompted me to restart my machine. Now the problem is I can't login from GDM becuase the input language is arabic, and my username is in english. I want my default language to be english. I think the default language now is arabic instead of english. I can't change the language at all. Basically I can't use my laptop at all.

I thought I had the solution when I choosed recovery mode in grub menu, and logged in using a shell, then I wanted to stop GDM from appearing, so I can change the default language settings after logging in successfuly. Well,... then I realized I don't know how to do it (stop GDM from starting) from the command line. Can anyone help?

housam
June 21st, 2008, 09:24 AM
we will suppose that you forgot your password. follow this guide it may help :http://www.psychocats.net/ubuntu/resetpassword (http://www.psychocats.net/ubuntu/resetpassword)

Abu_Dayya
June 21st, 2008, 09:51 AM
Thanks housam. But I don't think that will do the trick. Cause even if I changed my password, I still have to login through GDM, and my problem is wrong default language.

I think I know the solution, I just don't know how to do it using recovery mode from the grub menu. The solution could be either:

- Change default language to English USA (using CLI)
or
- Stop GDM from autostarting, like when you do it from (System -> Admin -> Sessions) using gnome, but this time through CLI

Guys?

MasterSander
June 21st, 2008, 10:23 AM
You can always login in the terminal by pressing ctrl+alt+f<1-6>, the problem is you will also be prompted to login, else you could uninstall the language pack through the terminal.

Abu_Dayya
June 21st, 2008, 12:56 PM
else you could uninstall the language pack through the terminal.

Yea, thats plausable. How do I find the name of the language pack

sudo apt-get remove "What is the name of the Arabic language pack" ??

Abu_Dayya
June 22nd, 2008, 10:21 AM
Again Guys, Does anyone know the command to :

- Change default language from whatever it is now to English USA

- Stop GDM from autostarting, like when you do it from (System -> Admin -> Sessions)

- uninstall the arabic language pack

MasterSander
June 22nd, 2008, 10:37 AM
You don't have to remove gdmgreeter from the sessions, just type top in the terminal and killall gdmgreeter. The language pack is language-pack-ar-base or language-pack-ar-gnome-base (replace by KDE if you got kubuntu)

MasterSander
June 22nd, 2008, 10:37 AM
type startx in terminal to start GUI also.

WitchCraft
June 22nd, 2008, 11:08 AM
You could try to boot with the live-cd and then change the language in the gdm config file...

sujoy
June 22nd, 2008, 11:16 AM
edit your xorg.conf in /etc/X11/

Option "XkbLayout" "us"

that should change the default keyboard layout to us.