PDA

View Full Version : [xubuntu] 3.4gb RAM on xubuntu



syn0ptik277
June 21st, 2008, 06:48 AM
i have just installed 64-bit xubuntu on a machine with 4bg of RAM but it only recognises the computer as having 3.4gb. Any ideas as to why its only picking up 3.4gb RAM

CloudFX
June 21st, 2008, 06:52 AM
Are your RAM cards separate or one large one?

jordanmthomas
June 21st, 2008, 08:10 AM
How much video memory do you have?
It counts toward that maximum of 4GB 32-bit OSes have.

ladr0n
June 21st, 2008, 08:13 AM
How much video memory do you have?
It counts toward that maximum of 4GB 32-bit OSes have.
He's using a 64 bit OS, though.

sdennie
June 21st, 2008, 08:31 AM
Are you positive you've installed the 64bit version and not the 32bit version? What your describing is a very common 32bit problem with 4G of RAM. Can you post the output of:



uname -a


and



free -m

lazyart
June 21st, 2008, 09:11 AM
It a fault of your motherboard. Go into your BIOS setup and see if you can remap the memory hole. If not you're stuck with it. My system did the same thing to me, then I found the setting and it released the rest of the memory. And yes, I'm running 64 bit.

syn0ptik277
June 21st, 2008, 12:12 PM
lazyart was right, it was the motherboard

Eiríkr
February 5th, 2009, 07:46 PM
I just replaced Fedora 9 with Ibex 64bit, and I've run into this problem -- 6GB installed, only 3.4GB visible. I'll reboot here in a sec and check out the BIOS...

LowSky
February 5th, 2009, 08:03 PM
Im using 4GB of RAM on Ubuntu 64bit and it is shouwing up as 3.9 which is correct... For some reason Ubuntu has some weird issue and 64MB is allocated for something or another during boot.

Other things to make sure of is that you use the correct slots for multiple RAM sticks, and that you are using the right voltages and such.
If you have on board video, it can use up to 512MB, on some of the newest boards.

Eiríkr
February 5th, 2009, 09:30 PM
Still mysterious -- the BIOS definitely sees all 6GB, but Ubuntu does not. Yep, the sticks are in the right slots -- 2GB each in 1 & 3, 1GB each in 2 & 4. I haven't touched the voltage settings at all. Moreover, Fedora 9 seemed to see all 6GB just fine last night before I overwrote it with Ubuntu Ibex. All of this makes me think that something's wrong with Ubuntu. And yes, for the record, I definitely installed the 64bit version -- I'm looking at the ISO file on my other machine, distinctly labeled ubuntu-8.10-desktop-amd64.iso.

Now, I *did* download the iso a few weeks ago, so is it possible someone at Canonical goofed and the 64bit iso had some bizarre issues in it? Or is the desktop kernel somehow crippled in the memory addressing department?


eirikr@Boreas:~$ uname -a
Linux Boreas 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux
eirikr@Boreas:~$ free -m
total used free shared buffers cached
Mem: 3519 898 2621 0 16 240
-/+ buffers/cache: 641 2878
Swap: 1482 0 1482
eirikr@Boreas:~$

Any advice welcome.

Cheers,

-- Eiríkr

LowSky
February 5th, 2009, 09:47 PM
just so you know, under your profile name on the left, it says your using 7.10, you might want to fix that

According to THIS (http://www.linuxforums.org/forum/other-distributions/57882-trustix-linux-not-recognizing-ram-greater-than-4-gb.html) You need to recompile the Kernel to accept more than 4GB, for some reason your install didn't register the RAM from the start

According to THIS (http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2008-07/msg01793.html) using the server kernel should support up to 64GB of RAM

Eiríkr
February 5th, 2009, 10:09 PM
Hey, thanks for the heads-up about my profile -- I've been 'away' for a while over in Fedora Land. :)

Looking into your links, I find no mention of any HIGHMEM config options in /boot/config-2.6.27-11-generic. There are other options including the string "MEM", but I don't know enough about kernel ops to tell what they do. I can post those here if needed.

The second link, about the server kernel, is interesting, but the very next post in that thread (http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2008-07/msg01798.html) advises using the 64-bit version of the generic kernel -- which I'm already doing.

All very puzzling. I don't have time to try the server kernel just now (in fact I *really* need to get cracking on some other work), but maybe later this evening PST.

Cheers,

-- Eiríkr

Eiríkr
February 5th, 2009, 10:42 PM
Okay, so I'm a glutton for punishment (and a heck of a procrastinator) -- I grabbed the server kernel off the repo and gave that a twirl. No dice.


eirikr@Boreas:~$ uname -a
Linux Boreas 2.6.27-11-server #1 SMP Thu Jan 29 20:13:12 UTC 2009 x86_64 GNU/Linux
eirikr@Boreas:~$ free -m
total used free shared buffers cached
Mem: 3519 1020 2499 0 23 382
-/+ buffers/cache: 613 2905
Swap: 1482 0 1482
eirikr@Boreas:~$

I'm at a complete loss here. Anyone have any clues?

-- Eiríkr

Eiríkr
February 8th, 2009, 11:29 AM
Since the discussion was rapidly moving out of "Absolute Beginner Talk" territory, I posted a continuation over in the "x86 64-bit Users" forum, in Thread 1061673.