PDA

View Full Version : [ubuntu] Hardy Heron updated, Ubuntu fails to load



lilbluegremlin
June 21st, 2008, 02:40 AM
Hello,
so i finally got around to updating Ubuntu to 8.04 or Hardy Heron. it all installed fine but when i restarted my box it booted up went to the loading Ubuntu screen then just went black.
i can boot into safe mode but don't know what to do there to fix or find out what needs to be fixed. can any one help me or point me in the right direction?
thank you,
ČErik

Rocket2DMn
June 21st, 2008, 06:42 AM
From safe mode, run

sudo dpkg-reconfigure xserver-xorg -phigh
then restart X with CTRL+ALT+BACKSPACE or just reboot normally.
That will reset your xorg.conf file.
If you have further problems, can you pleaes post

lspci | grep VGA
cat /etc/X11/xorg.conf
Also please tell me if you have installed restricted drivers and how you initially did that (manually? Hardware Drivers? Envy?).

Deutscher Alex
June 21st, 2008, 07:35 AM
I don't mean to thread-hijack, but I'm having the same problem (I think).
video/graphics driver no longer works after a reboot. If i try to reactivate my driver through Hardware Drivers OR through envy, it completely screws up the display and I have to run
sudo dpkg-reconfigure xserver-xorg -phigh I initially installed NVIDIA driver through Hardware Drivers in System > Administration, and it worked fine from kernel 2.6.24-16 through 2.6.24-18.

Rocket2DMn
June 21st, 2008, 08:23 AM
With newer kernel versions you may have to reinstall the driver. So you should remove the old driver from however you installed it (particularly Envy or if you did it manually from nvidia's website). Then reinstall the driver while using the newer kernel. If you are using Envy and Hardy Heron, make sure you use EnvyNG.

Deutscher Alex
June 21st, 2008, 08:04 PM
With newer kernel versions you may have to reinstall the driver. So you should remove the old driver from however you installed it (particularly Envy or if you did it manually from nvidia's website). Then reinstall the driver while using the newer kernel. If you are using Envy and Hardy Heron, make sure you use EnvyNG.

I tried this multiple times to no avail.

Rocket2DMn
June 21st, 2008, 08:08 PM
Does it work if you boot into an older kernel (you may have to reinstall the drivers from there to test it)?

Deutscher Alex
June 21st, 2008, 09:02 PM
Does it work if you boot into an older kernel (you may have to reinstall the drivers from there to test it)?

nope; i spent 3 hours testing it through the older kernels

lilbluegremlin
June 23rd, 2008, 01:03 AM
From safe mode, run

sudo dpkg-reconfigure xserver-xorg -phigh
then restart X with CTRL+ALT+BACKSPACE or just reboot normally.
That will reset your xorg.conf file.


i followed this and it fixed my problem. i booted in just fine. thank you

lilbluegremlin
June 23rd, 2008, 03:55 AM
now my problem is that Ubuntu will load but so far it has not let me install any ati drivers i have tried the ati driver from the hardware driver which loaded fine but when i rebooted it went to the black screen again after after loading but before the login screen.

i have also tried the ati driver installer from ati's site for linux computers.
i used

$ sudo sh ati-driver-installer-8-6-x86.x86_64.run
to run the file which installed fine. it did put out after i was done that the DKMS part of installation failed. i'm not sure what that means.
when i restarted after doing this it again went to the black screen after loading but before log in. ill keep trying different methods of installing the ati drivers but any help would be amazingly awesome!

Rocket2DMn
June 23rd, 2008, 05:31 AM
Can you please post the output of the two commands I listed in my first post, please:

lspci | grep VGA
cat /etc/X11/xorg.conf

lilbluegremlin
June 23rd, 2008, 09:35 AM
$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (rev 9a)



$ cat /etc/X11/xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

there ya go, thank you for keeping up with the thread.
i have been able to get it to load with the hardware drivers provided via Ubuntu but still no direct rendering or the ati drivers instead of the mesa one.

Rocket2DMn
June 23rd, 2008, 06:28 PM
I have heard about the dkms problem you had, I think you are supposed to recompile part of the kernel or some garbage like that - I don't recommend it.
A lot of people upgrading to Hardy have had problems with their ATI cards, and although some are able to fix them, many times the best thing to do was to do a fresh install of Ubuntu Hardy. I know that's not what you want to hear, but if you backup all your data, including your /home folder, a fresh install shouldn't take too long to get configured the way you like.
It's your call.

lilbluegremlin
June 23rd, 2008, 08:07 PM
well a fresh install would be cleaner thats for sure. all the various methods ive tried have put various amounts of non working stuff on my comp im sure. i hope i can still fit everything on my external. well off to dl hardy and backing everything up!

Rocket2DMn
June 23rd, 2008, 08:37 PM
Cool. Don't forget to back up your /home folder, this has hidden files and folders that store settings for programs. This means you won't have to reconfigure all your programs, just reinstall them. No GUI stuff is stored here, so we will still achieve the point of the reinstall.

Deutscher Alex
June 23rd, 2008, 10:08 PM
Cool. Don't forget to back up your /home folder, this has hidden files and folders that store settings for programs. This means you won't have to reconfigure all your programs, just reinstall them. No GUI stuff is stored here, so we will still achieve the point of the reinstall.

alright it looks like i'll have to resort to reinstalling Ubuntu. How would I go about backing up my /home folder? Can I just copy and paste it into /
?

Rocket2DMn
June 23rd, 2008, 10:15 PM
If you have an external hard drive, you can back it up by a number of methods. Have a look at this page: https://help.ubuntu.com/community/BackupYourSystem - i suggest using Simple Backup or TAR. Just don't overcomplicated it, you only need your /home/<username> directory.

Deutscher Alex
June 24th, 2008, 07:31 AM
I have heard about the dkms problem you had, I think you are supposed to recompile part of the kernel or some garbage like that - I don't recommend it.
A lot of people upgrading to Hardy have had problems with their ATI cards, and although some are able to fix them, many times the best thing to do was to do a fresh install of Ubuntu Hardy. I know that's not what you want to hear, but if you backup all your data, including your /home folder, a fresh install shouldn't take too long to get configured the way you like.
It's your call.

Alright I backed up my /home directory through tar. To do this "fresh install" do I have to first uninstall Ubuntu somehow and then reinstall it, or can I just reinstall Ubuntu from a live CD, overwriting the current installation?

Rocket2DMn
June 24th, 2008, 07:39 AM
You can overwrite what already exists. During the installation you can select to use the entire disk, this will wipe out what is already there. The default option is to use empty space, which you don't want.

Deutscher Alex
June 24th, 2008, 06:37 PM
You can overwrite what already exists. During the installation you can select to use the entire disk, this will wipe out what is already there. The default option is to use empty space, which you don't want.

Ok that what I did =).
It's working now, but it's pretty laggy. I'll install the (204) updates first and see if it gets better (not including the kernel updates!!)

EDIT: 194 updates installed, lag gone <3

lilbluegremlin
June 25th, 2008, 03:49 AM
Ok so i did a fresh install of hardy and then updated and installed the restricted driver. then after a restart it loads Ubuntu and goes to the log in screen. hover once i log in the screen turns black then white. if i alt-ctrl-backspace it shows the background as part of the log out and the log in screen. booting in the safe mode and trying to use the package repair or the xfix does not work neither does
$ sudo dpkg-reconfigure xserver-xorg -phigh
i also tried booting into the 2.6.24-16 rather then the 24-19 but still no change.
would removing the restricted drivers fix this? which was what i thought the above code did.
please let me know what to do.

Rocket2DMn
June 25th, 2008, 03:51 AM
Ok so i did a fresh install of hardy and then updated and installed the restricted driver. then after a restart it loads Ubuntu and goes to the log in screen. hover once i log in the screen turns black then white. if i alt-ctrl-backspace it shows the background as part of the log out and the log in screen. booting in the safe mode and trying to use the package repair or the xfix does not work neither does
$ sudo dpkg-reconfigure xserver-xorg -phigh
i also tried booting into the 2.6.24-16 rather then the 24-19 but still no change.
would removing the restricted drivers fix this? which was what i thought the above code did.
please let me know what to do.

Probably, try

sudo apt-get remove --purge xorg-driver-fglrx
sudo dpkg-reconfigure xserver-xorg -phigh
Then reboot or restart X.
Once back in the GUI you can try using EnvyNG to install restricted drivers - http://albertomilone.com/envyngfaq.html#A

lilbluegremlin
June 25th, 2008, 05:57 AM
the code you listed did work in allowing me to get back into the gui.
then i did install envyNG and ran it. it installed the drivers. then when i restarted it would load ubuntu then go blank. after using xfix and the package repair in safe mode it would goto the log in but when i logged in it again went black then white right after.
now what?

Rocket2DMn
June 25th, 2008, 06:26 AM
Boot into the recovery mode kernel and run

envyng --uninstall-all
sudo dpkg-reconfigure xserver-xorg -phigh
to get back to the normal setup again. You might need to search the forums a bit to see if other people have had problems with your make/model of video card, perhaps somebody has a more elaborate solution.
The alternative is to try installing the restricted drivers from ati's website - http://ati.amd.com/support/driver.html
If you do, don't delete the installer since you need it to uninstall the driver if it screws up.

tehman
June 26th, 2008, 05:27 PM
I'm having pretty much identical problems. :confused: I have just installed HH but i think we did update the kernel prior to video drivers. With the ati restricted driver installed with envyng, i restart into a black screen. if i boot into recovery, fix xserve and damaged packages, try to login to xserver, i get white screen. boot into recovery, then fix xserve and packages, then login to fail safe gnome, works fine but with mesa drivers. I have a radeon 1300. a buddy of mine was trying to figure it out and told me that my xorg.conf is much shorter than should be and wasn't listing a lot of things like my resolution list. anyway, he mentioned a command that would prompt you for supported resolutions and other settings allowing you to configure your xorg.conf pretty much like a wizard would. i plan on trying some of the above codes in just a minute and I'll post results. thanks in advance.

Rocket2DMn
June 26th, 2008, 07:11 PM
Hardy Heron uses a new version of X that relies more on autodetection than it used to, so xorg.conf is different than before. You should try removing the restricted drivers, then rebooting into the newer kernel and reinstalling them from there.

tehman
June 26th, 2008, 07:13 PM
just tried reinstalling HH. install seems to be stuck on a black screen. been there for about 15 minutes. hesitant to restart during an OS install, but...

Rocket2DMn
June 26th, 2008, 07:22 PM
Try installing from the alternate cd, it uses a text based installer rather than a live session, but it is still intuitive and easy to use - http://www.ubuntu.com/getubuntu/download
Check the box at the bottom of the page for the alternate disc.

tehman
June 26th, 2008, 08:39 PM
I'll try that alternate cd. However, when I did restart, it started pretty much ok (after redirecting my bootloader AND grub...) enabled restricted drivers and added the ati driver before updating anything and that was no good. Then I disabled restricted d/ls, removed the ati driver, started the updates and now black screen again and i'm hesitant to restart. does ubuntu have a power saver feature by default? lol

update: i'm dumb. ubuntu DOES have blank screensaver enabled by default. apologies.

AWende
June 26th, 2008, 09:00 PM
Had the same problem. Did a clean installation which went fine. After the installation, the system had to reboot. After showing the bootloader for a few seconds the screen turns black and nothing happens anymore. Fixed this problem easily however by pressing "Esc" when GRUB is loading, starting Recovery Mode and choosing the option named "Try to fix X server", which fixed the black screen problem.

tehman
June 26th, 2008, 09:46 PM
Ok...I would say this bit of information pretty much settles my problem...

"Unsupported

You are currently not able to use the "radeon" driver for the following cards and derivatives:

X1300 / R515 based cards.
X1600 / R530 based cards.
X1800 / R520 based cards.
X1900 / R580 based cards.

For these cards you must use the "fglrx" driver, or the new open-source "radeonhd" driver (no 3D, and in development). "

found here
https://help.ubuntu.com/community/RadeonDriver#head-b60183e198b030e0c2d76385685c6073aec882af

As far as I'm aware, neither of those driver options will support the enhanced effects, so I'm pretty much looking at a new video card if I care about it that much.

Rocket2DMn
June 26th, 2008, 09:50 PM
You need to install the restricted fglrx drivers. First look under System->Administration->Hardware Drivers, and if that one fails, try EnvyNG - http://albertomilone.com/envyngfaq.html#A

tehman
June 26th, 2008, 10:04 PM
envyNG is only allowing my to install ATI drivers...8.4. I assume those are the drivers that do not work with my card. I've also tried the HW Drivers manager before with the same results as always. i found mesa updates and i'm going to try those out, then try the HW drivers manager again.