PDA

View Full Version : [ubuntu] Slow wireless connection (linksys pcmcia card)



ptnewby
June 20th, 2008, 05:52 PM
I all, I have just installed ubuntu 8.4 onto my laptop wireless internet is working perfect apart from the connection speed i am getting is very slow.

when i check my connetion info m speed is only 1-5 mb/s max

it also says 802.11 WiFi (wlan0) my card is 11g is there some setting i need to change? to allow upto 54mb?

many thanks

chili555
June 20th, 2008, 07:47 PM
Please try, in a terminal:
sudo iwconfig wlan0 rate auto

ptnewby
June 22nd, 2008, 10:26 AM
Hi, ive tried doing as suggested with no avail :-( i'm still only connecting at 1MB per second? could it be i need to install or update the drivers? using a linksys WPC54G ver 1.2

thanks again

ptnewby
June 26th, 2008, 09:57 AM
Any one have any ideas or able to help…?this is driving me nuts!!

Arcadian
July 1st, 2008, 09:14 PM
Change the above command from "sudo iwconfig wlan0 auto" to "sudo iwconfig wlan0 54M". I've just tested the auto setting myself & it sets you back to 1Mb/s. Make sure you reconnect to your wireless network after setting it to 54Mb/s to get the new rate (via Network Manager icon, then check rate under Connection information). BTW, this doesn't seem to stick after a reboot, I'm working on that...

Hope it helps :)

Arcadian
July 2nd, 2008, 10:32 AM
Okay, found it here http://ubuntuforums.org/showpost.php?p=5196903&postcount=16

Running "sudo gksudo gedit /etc/network/interfaces" it now looks like this...


auto lo
iface lo inet loopback

pre-up iwconfig wlan0 rate 54M

So, when I now startup & login for the first time, I get 54MB/s on my wireless every time & am happy again! :)

P.s. Disabling IPV6 properly https://help.ubuntu.com/community/WebBrowsingSlowIPv6IPv4 didn't make much difference here at all, and I've turned the avahi-daemon processes back on too.

rawtin
July 23rd, 2008, 02:51 PM
Hi. I tried all the above suggestions and all work except that any bit rate over 1M will shut the wifi down. Anything I can do?