View Full Version : [ubuntu] [SOLVED] GeForce 8600 install results in low-resolution only modes

June 15th, 2008, 01:43 AM
I recently installed Ubuntu 8.04 on a Dell Inspiron 530, then installed an Nvidia geforce 8600 PCI-express graphics card using the instructions on the Nvidia site

( http://www.nvidia.com/object/linux_display_ia32_173.14.05.html )

When I rebooted, only low-resolution modes are supported (800x600 and 640x480, see xorg.conf below). I ran nvidia-xconfig and restarted, which didn't do anything.

As an alternative, I tried installing the packages Ubuntu recommended (nvidia-glx-new? maybe?), which I think made things worse.

"System -> Administration -> Hardware Drivers" says that the "Nvidia accelerated graphics driver (latest cards)" is enabled and in use.

I noticed this output in dmesg below, but it doesn't make sense to me, nor am I sure how to fix it (this is with the drivers that Nvidia says are the latest?)

Any help is appreciated, I've heard the 8600 is a sweet graphics card. :-)

$ dmesg
[ 44.323864] NVRM: API mismatch: the client has the version 169.12, but
[ 44.323866] NVRM: this kernel module has the version 71.86.04. Please
[ 44.323867] NVRM: make sure that this kernel module and all NVIDIA driver
[ 44.323868] NVRM: components have the same version.

$ uname -a
Linux lucas 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux

$ sudo lspci -v
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1) (prog-if 00 [VGA controller])
Subsystem: eVga.com. Corp. Unknown device c750
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at f8000000 (64-bit, non-prefetchable) [size=32M]
I/O ports at df00 [size=128]
[virtual] Expansion ROM at fb000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0

$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"

June 15th, 2008, 01:46 AM
I have this computer and the same video card. I installed the restricted nvidia drivers using EnvyNG - http://albertomilone.com/envyngfaq.html#A
You can also check System->Administration->Hardware Drivers to enable restricted drivers (you should probably try this first).

June 15th, 2008, 02:05 AM
Thanks very much Rocket2DMn! The main problem looks fixed (thank heavens!), but I have a couple smaller issues.

I ran the NVidia driver uninstaller

$sudo sh Desktop/NVIDIA-Linux-x86-173.14.05-pkg1.run --uninstall
(which I didn't know I could do!)

and then used EnvyNG to automatically detect / install the NVidia driver. After rebooting, the dmesg error disappeared and I'm running 1280x1024 again (which is wonderful), but only at 50Hz (only 50Hz and 51Hz are available?) I was hoping to run 60Hz.

Also, "System -> Administration -> Hardware Drivers" says the NVidia accelerated graphics driver is not enabled / not in use. Is that expected?

I'm about to try dual monitors, we'll see how that goes.

Thanks again for your help!

June 15th, 2008, 02:11 AM
I think that area that it is showing the refresh rate of 50hz is incorrect, it's a bug or something. It should already be running at 60hz.

I tried the 173.* drivers, and i think they worked, but didn't provide any extra benefit (I was trying to troubleshoot wine), not sure why they didn't work for you.

Don't worry about the Hardware Drivers manager, it's questionable, IMO.

Dual monitors should go well, use the nvidia-settings program (I forgot where it is under Applications or System, though I think it's under System->Administration - I'm not at my desktop to check). I recommend starting with the basic extended desktop, Twinview. You can fiddle with Xinerama later if you want to try that.

June 15th, 2008, 02:28 AM
You're right on, again. Even dual monitors is working now with TwinView.

I spent 4 hours trying to get this working before I posted here. I wish I'd just asked and saved the time! Thanks so much, Rocket2DMn!


"System -> Administration -> Screen Resolution" still says it's running 50Hz, but "System -> Administration -> NVIDIA X Server Settings" says both monitors are running at 60.02Hz.

"System -> Administration -> Hardware Drivers" says the card isn't enabled, but when the display manager boots up, it displays a full-screen NVIDIA logo, so I don't care. :)

I notice that the Nvidia configurator claims to save to /etc/X11/xorg.conf, but it didn't ask for sudo and couldn't (silently) write the file. I saved it to my home directory and sudo mv'd it.

June 15th, 2008, 02:37 AM
Yeah, I've had that last problem myself. I just copied the contents of the xorg.conf file it had and manually put them into xorg.conf. Whatever works best for you :)