PDA

View Full Version : [xubuntu] "Allow Xfce to manage the desktop" won't stay across sessions



mksql
June 13th, 2008, 04:32 AM
After an issue where my disk filled to capacity, and some desktop settings got damaged, I have one problem left to resolve.

When I login to an Xfce session, the desktop is initially OK, but then reverts to the default Heron backdrop and a different icon layout. I have to go into Desktop Preferences in the Settings Manager, and re-check "Allow Xfce to manage the desktop". Selecting he save session option on logou does not help.

Is there a config file for this setting that may be damaged?

Xiong Chiamiov
June 13th, 2008, 04:41 AM
Did you start from scratch again, or modify an existing profile? If the latter, it might be a permissions issue - try making sure your ~/.gnome2 (I believe that's the one used by XFCE) folder is owned by you, and you have read and write permissions.

mksql
June 13th, 2008, 04:59 AM
I am still using the original profile. Checked the ~/.gnome2, and my user is the owner.

Xiong Chiamiov
June 13th, 2008, 05:09 AM
You might try changing the permissions appropriately (even though they should be right), just to apply it down to all the folders within.


chmod -R 755 ~/.gnome2

mali2297
June 13th, 2008, 12:33 PM
Do you use Nautilus?

If so, make sure that you start it with the command
nautilus --no-desktop

mksql
June 14th, 2008, 12:40 AM
Do you use Nautilus?

Thanks, that reminded me that an experiment installing Nautilus occurred right before this problem started. Backing out the unneeded components solved the problem.

Nobby
July 1st, 2008, 07:14 AM
Hi, I am also experiencing this problem where the setting "allow Xfce to manage the desktop" just won't stick.
I've had ubuntu hardy installed previously (fresh install) and just installed the xubuntu-desktop package. I've been into the gconf editor and unchecked the option apps/nautilus/preferences/show desktop, and I don't use nautilus anyway. I've tried creating a new session, with the 'automatically save session on logout' option checked, but nothing seems to work. :confused:

eggkrate
December 20th, 2008, 08:56 PM
Thankyou for this help. I un-installed Nautilus and my problem with Xfce switching to gnome desktop was fixed.