PDA

View Full Version : [ubuntu] Hal Missing - But I can see it when i mount it! HELP!



abshirf2
June 12th, 2008, 01:55 PM
HELP!!!

I think i've messed things up now!

I have just installed ubuntu serer edition 8.04. I already had ubuntu desktop and windows xp and windows xp (yes 2 of them) on one machine, I was asking for trouble!!

Now i get the usual hal.dll missing error. I opened ubuntu mounted both windows and hal.dll is there. I even replaced it, but I still get the same error on startup! ALso when i shutdown ubuntu server i get something like hal_init() error, no idea, it shut downs too quick to read.

PLEASE HELP ME FOR THE LOVE OF GOD!!! xD

Thanks :)

abshirf2
June 12th, 2008, 02:24 PM
I just tried another tutorial which edits the boot.ini file, i couldn't follow it because i couldn't find the boot.ini!!! What does that mean??!

HELP!

jwrobbie1
July 28th, 2008, 02:49 PM
I had the same problem. I installed Ubuntu from CD and selected the "within windows" option. This was "big mistake". The install went through the install and rebooted. I got a "missing HAL.DLL" during boot. I was able to boot from XP cd and copy a copy of the HAL.DLL from my system backup. I have live backup running on PC (Atempo) and retrieved the latest version of this file. I tried booting from disk again, and could get no futher than the missing or corrupt "HAL.DLL" message. Long story short, I had to rebuild PC's Windows OS. Recovery took 6 days.
I would not recommend installing ubuntu ... at least by taking the from "within windows" option.
-good luck