PDA

View Full Version : [gnome] 8.04 dual head landscape.. ati.. gnome ignores xorg.conf



cameron20020
June 8th, 2008, 04:34 AM
alright,
so I installed the 32bit version of ubuntu 8.04,
installed the ati drivers for my radeon hd 3870,
and yes i have 2 monitors, one 20" chimei, connected by dvi,
and one diamond view 14" connected by vga, as it dont have dvi...

ANYWAYS... on the install ubuntu detected both screens properly,
BUT could only run them in clone view mode, not stretch desktop accross 2 screens, after the install, the same problem. cept now the screens arent detected, they are just seen as one unknown monitor..

SO.. i ran ati catylist control center (amdcccle) and set the desktop to big desktop, so my desktop is stretched accross 2 screens, works a charm,
it even detected the screens perfectly, so all is good, i applied the settings, and even the login screen is setup in dual screen layout... but..
as soon as a log back into gnome, it goes back to clone, until i run ccc again to fix it up....

I think gnome is ignoring the xorg.conf, but how would i make gnome stop fiddling with the displays?

bazzer
June 9th, 2008, 11:44 AM
I think it uses xrandr now, so maybe figure out what settings you need to pass it and add the line to your .xprofile?