PDA

View Full Version : [ubuntu] [SOLVED] error 00000000-60000000



novatotal
June 5th, 2008, 09:49 PM
as you may have read in the thread internet exploiter installed? I get this error preloader: Warning: failed to reserve range 00000000-60000000

this is the "solution" in winehq but does not work!!
anybody managed to make it work?
edited the etc/sysctl. conf and saved it but still no icon!!
also read this will lower the security of my ubuntu so I will edit the etc/sysctl.conf back to original

Wine Wiki
WineHQ Menu

* Wine

PreloaderPageZeroProblem

Running Wine on recent versions of Linux (in particular Ubuntu 8.04, Hardy Heron, and Fedora 9) may generate errors or warnings such as

preloader: Warning: failed to reserve range 00000000-60000000
err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space,
please report

or

winevdm: unable to exec 'Z:\tmp\CONFIG.EXE': DOS memory range unavailable

and may refuse to run Wine applications, especially ones that use DOS calls. For instance, Microsoft Word 2000 will crash after a few seconds (does this still happen in rc1?)

One bad workaround is to run as root. Don't do that. If you do this, your .wine directory will be screwed up, and can't be used anymore without running as root. (To recover from this, either delete your .wine directory as root, or maybe use chown -R $LOGNAME .wine to fix ownership.)

The right workaround is to give the command:

$ sudo sysctl -w vm.mmap_min_addr=0

This fixes the problem until the next time you reboot. (It also reduces security slightly.)

To avoid having to give that same command every time you reboot, also edit the file /etc/sysctl.conf, e.g. with the command

$ sudo gedit /etc/sysctl.conf

and change the line that reads:

vm.mmap_min_addr = 65536

to:

vm.mmap_min_addr = 0

That will apply the workaround for you when the system starts.

Distributions may wish to include this workaround when they package wine.

For more info, see

*

Wine Bug 12516
*

https://launchpad.net/bugs/114025
*

http://kerneltrap.org/Linux/2.4.36_Stable_Release
*

http://kerneltrap.org/Linux/Patching_CVE-2008-0600_Local_Root_Exploit

and also

*

Wine Bug 7848

Translations:

*

Problema PreloaderPageZero (Español)

PreloaderPageZeroProblem (última edición 2008-05-28 10:05:29 efectuada por DanKegel)

novatotal
June 8th, 2008, 05:57 PM
hey guys believe it or not I did solve the issue off installing internet exploiter on my desk!!!
heres the solution!!!(stupid of me didn't think off this earlier)
turns out that in the installation, ies4linux tells you it will install on desktop, now that translates to spanish as (escritorio) so I kept looking for the icon there, turns out I have a desktop folder and then there's the actual desktop!! and the icon did install, but on the desktop folder not on my "escritorio" all I did was move the icon from the folder to the "escritorio" and that's it!!!! hope I was clear enough!! if not, fell free to ask all of you fellow linux users that need to install that piece off m$ monopoly!!!! linux rocks!!!!:guitar:

novatotal
June 8th, 2008, 05:58 PM
sorry for the double popst forgot to mention that you do not need to implement the solution on wine hq!!!!!!:guitar: