PDA

View Full Version : [gnome] Menu bar frozen



kazoo boy
June 5th, 2008, 02:47 AM
hey, it seems that my menu bars in Gutsy are frozen. When I log in, I can't get a response when I click the "Applications" or any other menu. I can still open the icons on the desktop though. Also, I can right click the applets on the bottom bar, and the usual right-click menu pops up asking me if I want to remove the applet ect. When I try to press Ctrl-Alt-Del it pops up with the typical shutdown/logout options, but when I try to restart or shutdown, it locks up and I have to force power off the system.

I've had warnings about the gnome application settings daemon before, but usually re-logging in fixed the problem. Also, I think the menus worked mostly fine. I don't know if that has anything to do with it or not.

anyway, I'm wondering if I should just update to Hardy, but it would be kind of annoying because I want to upgrade from a 64 bit to a 32 bit for compatibility reasons. Anyway, is there a fix, or should I upgrade?

mrMango
June 5th, 2008, 03:14 AM
This happens to me in Hardy as well. In fact, the panel hasn't frozen; it's hung up while waiting for one of your applets to load. I've been only able to get around it is to just wait it out, which can take up to 15 minutes.

After that time, the applets time out. I remove the offending applets, re-add them, and everything is happy again.

kazoo boy
June 5th, 2008, 03:42 PM
I tried waiting a couple of times. The last time, after waiting for half an hour, the menus were still frozen. However, I think you are probably right about the applets, because I'm pretty sure the last time I had logged in, I had installed the "Volume Control" applet, and I haven't noticed it appearing in it's place when I boot up now...

Is there a way to log in as terminal and disable it through there? I'm just not super comfortable about running just with the terminal, but I don't mind trying since it may be the only way.

However, I think I could still access the files in my system through the desktop icons, and I might be able to edit a system file if it doesn't require sudo.

jean noel
August 9th, 2008, 04:08 PM
Recently, I have encountered the same problem. On log in, I would see a message on the screen asking me to log to noaa for the weather. The menu would freeze.
My only way out was to log in with a different user name, (which is actually the case).
Any help?