PDA

View Full Version : [other] Root trash problem



Valsodar
June 3rd, 2008, 11:34 PM
running on Ubuntu 8.04 with Gnome

This is the problem I experience: if I run sudo nautilus and click the root trash from the left side panel nautilus freezes. My trash folder is located under /root/.local/share/Trash with permission drwx------ (or 0700, just like my normal user trash folder). I also noticed that if I type in nautilus address bar "trash:///" it comes with the following: Couldn't find "/root/.local/share/trash:".

Now this is not a big deal, I can aways use terminal to remove it or navigate nautilus to it and shift+delete but I wonder what is causing this? Any suggestions?

bullon
June 21st, 2008, 11:19 PM
I have the same problem, except that I have no idea how of how to empty my root trash from the terminal :S

aysiu
June 21st, 2008, 11:56 PM
Unrelated issue: the proper command is
gksudo nautilus not sudo nautilus. More details here: http://www.psychocats.net/ubuntu/graphicalsudo

No idea about the freezes. It could be anything from a crappy theme to a bad X configuration... or just a bug the Ubuntu developers haven't fixed or aren't aware of yet.

Valsodar
June 22nd, 2008, 04:27 PM
I tried gksudo nautilus, but the problem is persistent. I think this might be a nautilus problem. Anyhow to delete your root trash from the command line use:


rm -r /root/.local/share/Trash

However be extremely careful with that and I will recommend aways to use


rm -ri /root/.local/share/Trash

aysiu
June 22nd, 2008, 06:03 PM
Be extremely careful with that means make sure you paste that command instead of retyping it.