PDA

View Full Version : [gnome] Change icons, lettering



mopalia
June 2nd, 2008, 06:58 PM
I need to change the lettering below icons to plain solid black, no shadows. I also want simpler icons: no thumbnails/previews (especially not in .pdf or .jpg files), no colored panels in .odt icons -just really plain rectangles, like the message icon above. Everything in Gnome Art is too fussy or obtrusive. Any help?
Running Gnome Heron (Hardy)

Dylnuge
June 2nd, 2008, 07:03 PM
In your Visual Settings (under 8.04, right click on the desktop and choose the settings choice), you can shut off desktop effects.

If that isn't what's bothering you, there is a Fonts option inside your preferences menu, changing the system font may help.

-Dylnuge

mopalia
June 2nd, 2008, 07:12 PM
Thanks, I've done all that. The Fonts menu does not affect the fonts inder the icons. The effects menu doesn't relate to any of that, either. This took pretty deep manipulation in Windows under the Folders options, and it doesn't seem to be simple in Ubuntu, either.

mopalia
June 2nd, 2008, 08:14 PM
In your Visual Settings (under 8.04, right click on the desktop and choose the settings choice), you can shut off desktop effects.

If that isn't what's bothering you, there is a Fonts option inside your preferences menu, changing the system font may help.

-Dylnuge

Re: Change icons, lettering
Thanks, I've done all that. The Fonts menu does not affect the fonts under the icons. The effects menu doesn't relate to any of that, either. This took pretty deep manipulation in Windows under the Folders options, and it doesn't seem to be simple in Ubuntu, either.

Dylnuge
June 3rd, 2008, 04:10 AM
Did you change the font rendering type in Preferences -> Appearances -> Customize -> Fonts?

mopalia
June 3rd, 2008, 05:10 PM
Did you change the font rendering type in Preferences -> Appearances -> Customize -> Fonts?

Yes. It doesn't affect the font under the icons on the desktop.

mcduck
June 3rd, 2008, 08:46 PM
The icon text shadows can be disabled with by creating a ".gtkrc-2.0"-file in your home directory and adding a couple of lines there..


style "desktop-icon"
{
NautilusIconContainer::frame_text = 1
text[NORMAL] = "#000000"
NautilusIconContainer::normal_alpha = 0
NautilusIconContainer::highlight_alpha = 255
NautilusIconContainer::dark_info_color = "#222266"
NautilusIconContainer::light_info_color = "#dddddd"
}
class "GtkWidget" style "desktop-icon"

Actually that piece of code allows you to define icon text colors and text container opacity as well, but the important trick here is enabling the text container and then setting it's opacity to 0 to make it invisible. Enabling the container will disable the shadowed text..

mopalia
June 4th, 2008, 04:11 AM
Score! Thank you, mcduck, you have made me very happy. You are my hero.