View Full Version : force unmount /opt

October 24th, 2005, 04:43 PM
i need to unmount /opt but i keep getting this:

poobah@ds9:~$ sudo umount /opt
umount: /opt: device is busy
umount: /opt: device is busy

so i closed all applications except for the terminal and i still got the same result.

how do i force unmount?

October 24th, 2005, 08:30 PM
1) Reccommend that this be moved to one of the Support Forums

2) Is /opt on the same partition as the rest of the / file system? If so then you won't be able to unmount it

October 25th, 2005, 03:30 AM
thanks kyral!

it's not in the same partition.

i tried to force unmount it again

sudo umount -f /opt

again, it gave me a service is busy reply or something like that :mad:
i then rebooted it.
and ... voila! ... /opt is already unmounted after booting.:D

i don't get it. :confused:

November 7th, 2005, 04:25 PM
you could have umount withount rebooting with the following

umount -l /opt
man umount (search for lazy)

perhaps with a sudo

April 21st, 2011, 02:47 PM
that -l option was useful for me, thanks!

March 13th, 2013, 06:42 PM
"umount -l /opt" it works for me