PDA

View Full Version : [ubuntu] Graphics problem



celticbhoy
May 27th, 2008, 01:33 PM
I am having intermitent graphics problems. Every now and then when I log out the screen shows horizontal broken lines as though the resolution is set to high, and I can no longer work compiz.

after trying to update the graphic card driver I get this :-

gary@Ubuntu-0:~$ sudo apt-get install xserver-xorg-video-intel
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-video-intel is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up fusion-icon (0.0.0+git20071028-2ubuntu2) ...
pycentral: pycentral pkginstall: not overwriting local files
pycentral pkginstall: not overwriting local files
dpkg: error processing fusion-icon (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
fusion-icon
E: Sub-process /usr/bin/dpkg returned an error code (1)
gary@Ubuntu-0:~$


Anyone any ideas.

celticbhoy
May 27th, 2008, 01:34 PM
Forgot to say it is an Intel express graphics onboard chip

Capricori
May 27th, 2008, 01:36 PM
Try running sudo dpkg --configure -a.
Also, that graphic driver seems to already be installed, and the newest version.

alienexplorers
May 27th, 2008, 01:38 PM
Please list your:

lspci
&
xorg.conf

celticbhoy
May 27th, 2008, 01:39 PM
Just tried the sugestion, I am guessing the problem is to do with fusion icon affecting the graphics.

:-

gary@Ubuntu-0:~$ sudo dpkg --configure -a
Setting up fusion-icon (0.0.0+git20071028-2ubuntu2) ...
pycentral: pycentral pkginstall: not overwriting local files
pycentral pkginstall: not overwriting local files
dpkg: error processing fusion-icon (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
fusion-icon
gary@Ubuntu-0:~$

celticbhoy
May 27th, 2008, 01:41 PM
lspci :-

gary@Ubuntu-0:~$ lspci
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 Network controller: Intersil Corporation ISL3886 [Prism Javelin/Prism Xbow] (rev 01)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
gary@Ubuntu-0:~$

xorg.conf :-

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

babily
July 17th, 2008, 03:49 PM
I have the same problem.

hedrian
July 18th, 2008, 08:02 AM
i aslo got that prob but now its fixed..go to menu and choose safemode if your having gfx probs