PDA

View Full Version : [ubuntu] Installed video driver, now no display



jockmullin
May 23rd, 2008, 08:12 PM
Greetings.

Total newbie just installed Hardy on Dell Inspiron laptop. Was going great but I couldn't enable video effects so it said to install a new video driver which I did and rebooted as requested. Now at boot I see the startup but at logon screen goes black. I can still log in, but can't see anything.

Can I roll back the driver? How to boot to console?

Any help appreciated.

Jock

alienexplorers
May 23rd, 2008, 08:17 PM
What video card are you running and what driver did you load?

geezerone
May 23rd, 2008, 08:25 PM
Boot into safe mode for Ubuntu. Then at the command prompt type the following:


sudo dpkg-reconfigure xserver-xorgto reconfigure your xserver settings. Most are default settings and this will set screen resolutions as well as selecting your driver. With nvidia problem drivers you normally use nv instead of nvidia in the /etc/X11/xorg.conf file (edit with nano /etc/X11/xorg.conf command)

Let us know how you get on.

jockmullin
May 23rd, 2008, 08:28 PM
Bios saysNVIDIA GeForce4Go.
I loaded the GeForce driver (sounded like a good idea at the time :))

jockmullin
May 23rd, 2008, 08:30 PM
Bios says NVIDIA GeForce4Go.
I loaded the GeForce driver (sounded like a good idea at the time :))

subzero316
May 23rd, 2008, 08:30 PM
Boot normally ,
press CTRL+ALT+F1 you`ll enter console mode...

jockmullin
May 23rd, 2008, 08:34 PM
Hi, geezerone

OK that is what I was looking for.
Hwver, still stuck at "boot into safe mode". How is that done, pls.

Jock

alienexplorers
May 23rd, 2008, 08:43 PM
Hit <esc> when the grub loader starts loading and select from the menu safe mode.

jockmullin
May 23rd, 2008, 08:53 PM
Thanks guys.

Geezerone & Anish - bang on. Back in business now, many thanks.

Jock