PDA

View Full Version : [ubuntu] Staticmesh.fx error in running bf2142



fr0sty
May 21st, 2008, 10:37 PM
Hi. I don't know where to post this but when I try to run battlefield 2142 in wine, I get the following error. How do I fix that? ive googled a little but still have no clue on how to solve it. Thanks for any answers. I'm still kinda a noob at Ubuntu but get around quite well. Wine is version 9.59.

Ive included a pic of the error. hope i attached it properly

Frosty

fr0sty
May 21st, 2008, 11:22 PM
Nvm. i solved it and am able to play bf2142 perfectly in ubuntu via wine. thnx.

Bl00drav3n
June 3rd, 2008, 03:43 PM
So how did you solve this problem?

fr0sty
June 3rd, 2008, 04:18 PM
Hey everyone! This is frosty and sorry it took me so long to put up the answer to fix the staticmesh.fx problem. It is due to some missing Dlls so just google the following Dlls and place them in your "system 32" directory on the Wine C: drive. Here are the Dlls you need to download(without the quotations): "d3dx9_29.dll" "d3dx9_30.dll" and "d3dx9_32.dll"

Good luck with getting the game to run. I did and run it with full graphics excpet for lighting. If you need anymore help just message me. Punkbuster doesn't work in wine and PB said they dont support "emulation software." Well for their info its actually a "compatability layer", but there is no multiplayer without getting booted.