PDA

View Full Version : [ubuntu] 8.04 upgrade. No dvd playback in VLC/Totem



Les Oeufs
May 20th, 2008, 08:12 PM
I've already checked through this thread http://www.uluga.ubuntuforums.org/showthread.php?t=767449 but it seems they're having a different problem than I am.
I upgraded from 7.04 to 7.10 to 8.04 in the span of a week, so I didnt really do much work in 7.10, but I can tell you that my 8.04 upgrade is behaving exactly like my 7.04 install before I had libdvdcss2 (and its companions) installed.
In Totem, the error is "An Error Occurred: Cannot read from resource". But in VLC, I go to file> open disc, and when I open the disc the counter just reads 00:00:00/00:00:00, and it says Audio CD - Track 1, but nothing happens.
I checked the comprehensive sticky. Synaptic tells me I have libdvdcss2, libdvdread3, libdvdnav4, vlc
I ran these commands
sudo apt-get install build-essential debhelper fakeroot
sudo /usr/share/doc/libdvdread3/install-css.sh

and still nothing.
I uninstalled and reinstalled VLC and still nothing. I've also tried opening .vob files for ripped dvds I have on my hard-drive and they're also not working.
Can anyone help me out?
Thanks

edit: more info
I just got an error in gxine (just installed it), and it said it couldnt read dev/dvd. In VLC, it looks like its going for dev/scd0. I can find a file with that name in dev, but nothing with dvd.
Also, I previously mentioned that I couldnt open a ripped dvd on my pc. I tried another of the vob files, and it opened (both in VLC and totem), but it was just the video portion. Could it be the menus that are screwing things up?

cor2y
May 20th, 2008, 08:44 PM
Looks like you need the dvd libraries, libdvdcss2 libdvdnav and libdvdread you can install by adding the the medibuntu repos www.medibuntu.org bookmark it.
When you upgrade from previous versions sometimes some apps versions don't get updated correctly.
Your best bet is completely remove libdvdcss2 libdvdread libdvdnav, then reinstall them.
Select "completely remove" when you right click on them in synaptic or via the terminal

sudo apt-get purge libdvdcss2 libdvdnav4 libdvdread3 then add the medibuntu repos (if they have not been added) update then reinstall
sudo apt-get install libdvdcss2 libdvdnav4 libdvdread3
Then try again

Les Oeufs
May 20th, 2008, 09:31 PM
Gave that a go. Got rid of the old libraries, installed the medibuntu repos, reinstalled the libraries. Fired up VLC, didnt work.
Uninstalled/reinstalled VLC, still not working. Restarted my computer. Tried again, still didnt work. But in between stuff I fired up rhythmbox and it said I was missing the codecs (had them earlier), and somehow gstreamer got uninstalled. Reinstalled that, still not working.

williamson389
June 4th, 2008, 01:38 AM
i Have the same problem. USed to be able to play dvds then did a clean install when fixing wireless, and now disc doesnt even mount on desktop
only makes alot of noise from the drive

cariboo
June 4th, 2008, 02:33 AM
Can you play dvd's if you manually mount them?

try in a terminal:


sudo mount /media/cdrom

then try to play a dvd using your favorite application.

Jim