View Full Version : [kde] need help configuring torK

mamadu bwana
May 19th, 2008, 09:04 PM
I am trying to configure torK on my x386 computer running Ubuntu 8.04 and I am running into some problems. Could you please point me towards the right solution?

I installed torK, tor and privoxy without any problems.

I used the torK wizard to configure to to run as a client.

I configured torK to lauch tor when needed (tor is not started at bootup)

When I try to lauch torK from the "press play to get started" I get this message:

TorK couldn't start your Privacy Proxy!
Message: Nothing.
Reason: This may be because you have configured it to launch at system startup. If that is the case, and you have reason to believe it is configured to listen to Tor, then just click 'No' and take a look at the 'Konqueror' settings in the configuration dialog.
Would you like TorK to try restarting it again?

Then I choose 'yes' and I get:

Tor Couldn't Bind to One of the Addresses/Ports you configured!
Message: May 19 15:52:14.256 [warn] Could not bind to Address already in use. Is Tor already running?
Reason: Tor is probably already running. If you like, TorK can connect to the already-running instance of Tor and manage that for you instead. (You will have to open the configuration dialog and re-apply any settings you wished to use.)
Would you like to do this now?

and when I choose 'yet' I get:

TorK has passed an invalid configuration file to Tor!
Message: May 19 15:52:14.256 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
This means: Please report this using 'Help->Report Bug' in the menu. Try to provide as much detail as possible. Thanks!

What am I doing wrong? How do I manually start tor and privoxy and have torK use them?

I know that it is not my hardware or network because I ran torK off a live-CD and everything worked perfectly.

Many thanks in advance for any pointers!

May 25th, 2008, 06:45 AM
i'm having the same problem.

May 29th, 2008, 11:55 AM
anyone come up with an answer to this?

August 26th, 2008, 08:49 PM
Same problem.

September 14th, 2008, 07:22 PM
same problem here..
am behind a proxy with a smart filter feature..something like web sense, which prevents me from reaching websites like youtube.com and certain pages in the sourceforge.com domain...
can these applications help me out in this ?? if so..am having the very same problem as mentioned above..
any suggestions ??

October 7th, 2008, 05:46 PM
Got the same on my 8.04.
Why no one can see the bug in it? Do so little people use TorK?

October 12th, 2008, 03:25 AM
You could try first killing the tor process under
System -> Administration -> System Monitor. Then run TorK.

hope this helps...

November 20th, 2008, 12:07 AM
Here's what I've done to have a running smoothly and shiny Tor, TorK and privoxy :)
Before all that below you'll have to install it. I have choosed the TorK from universe repository, same for privoxy, and noreply.org repository for Tor. Let's add the noreply.org:

sudo kate /etc/apt/sources.list
and copy/paste there this:

deb http://mirror.noreply.org/pub/tor hardy main
deb-src http://mirror.noreply.org/pub/tor hardy main
then, of course

sudo aptitude update && sudo aptitude install tor tork privoxy
When you have all that stuff installed let's do some configuring.

Firstly, edit the privoxy config. It can be done by that:

sudo kate /etc/privoxy/config
then find a line

#forward-socks4a / .
and uncomment it. DO NOT delete that little dot at the end of the line :) Then restart privoxy.

sudo /etc/init.d/privoxy restart

Secondly, edit the Tor config. Type in Konsole

sudo kate /etc/tor/torrc
then find a line

#ControlPort 9051
and uncomment it. Then restart Tor by typing:

sudo /etc/init.d/tor restart
Next thing is to configure TorK, but this can be done by a First Run Wizard :)

February 5th, 2009, 06:14 AM
That worked beautifully. Thank you khaard!

March 28th, 2009, 11:21 AM
Thanks for the note khaard. Works beautiful now...

I only noticed on installing the packages that I got an error on Hardy.

Error message:

W: GPG error: http://mirror.noreply.org hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY CFF71CB3AFA44BDD
W: You may want to run apt-get update to correct these problems


First get the key:

gpg --keyserver hkp://subkeys.pgp.net --recv-keys CFF71CB3AFA44BDD

Then add the key:

gpg --export --armor CFF71CB3AFA44BDD | sudo apt-key add -


apt-get update

Thanks again!

April 10th, 2009, 03:26 AM
thank you khaard...

May 7th, 2009, 05:28 PM
thank you khaard...
and thank you ITCons too... :popcorn: