View Full Version : [ubuntu] [SOLVED] Ubuntu 8.04 + eeepc login issue

May 19th, 2008, 10:06 AM
Hello chaps,

I need help debugging an issue. I ran the LiveCD os 8.04 on my eeepc last night, which worked fine.

I've found a script here:

Which will fix the wireless, suspend, osd etc...

Anyhow, I've done the install, and rebooted as which point I've hit a brick wall.

The steps are thus:
1. I get to the login screen (GDM)
2. type in my username
3. type in my password
4. screen goes brown (as it would when GNOME is about to kick in)
5. at this point, it just sits there and doesn't progress

I can't tell if it's doing anything, as ubuntu is installed to the SD card, and not the SSD, so there is no access light.

Can anyone start me off with ideas about how I might start the debugging process to find out what is wrong?


May 20th, 2008, 07:09 AM
On the login menu try changing the Session to something other than what it defaults to. It could be something that is trying to run automatically when you login.

May 20th, 2008, 09:07 AM
It's something to do with the GNOME keyring, I have found a solution here:

The fix is thus -

Nano and create a new file here:

sudo nano /etc/hal/fdi/policy/removable_root_fix.fdi

Paste this in:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">

<match key="volume.mount_point" string="/">
<merge key="@block.storage_device:storage.removable" type="bool">false</merge>


Restart hal:

$ sudo invoke-rc.d hal restart

There's a bug listed in launchpad here: