PDA

View Full Version : [ubuntu] [SOLVED] white screen of nothingness



Stolea
May 19th, 2008, 01:23 AM
I just installed Ubuntu 8.04. It all started up fine and it notified me that there were some updates which I downloaded, including an Nvidia 3d driver.
On system restart I got to the bit where the startup sound plays and then I have a nice plain white screen with my mouse pointer. Makes a pleasant change from the windoze blue screen of death, but is pretty much the same outcome.:(
At a guess, its the graphics card driver that is causing the problem.
How do I reverse the install, or should I just reinstall?

iaculallad
May 19th, 2008, 01:33 AM
This might be an issue of Compiz/Desktop Effect. Try doing this:

- Do wait for the normal login sound to finish. Give, say, 15 seconds for all the desktop component to load.
- Press Alt+F2 to launch the "Run Application" dialog box. Dialog box would be in the background of your "White Screen" but its there.
- Try entering: metacity --replace then press Enter key.

That would probably bring back your GUI.

vrangforestillinger
May 19th, 2008, 02:43 AM
Yes. This looks like a bug many nvidia-users experience.

For me, this happens when I bring the computer back from hibernate, when Im switching users or whenever the screen is locked. The screen will be totally white, but the mouse is visible. When moving the mouse to somewhere in the middle of the screen, it changes to a text-cursor. This is where my password-prompt would normally be when the screen is locked. When clicking that invisible area, entering my password, the screen is unlocked, and Im back to the desktop again.

(If this is the case for you as well, then Alt+F2 won't bring up Run Application.)

As iaculallad wrote, changing to metacity (turning off 3d desktop effects) probably will fix the problem. I do this in the "Desktop Effects" tab of the "Appearance" menu. The command "metacity --replace" does the same job, but im not shure if the change will persist in the next login unless you do it from the appearance-menu. (Correct me if Im wrong.) If you have run "metacity --replace, then you might need to change this setting on and off for it to persist in next login.

Personally, I keep the effects on, knowing how to unlock the screen blindfolded.

(Launchpad entry here for more techy stuff: Bug #160264 (https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/160264). Jugding by the comments, a fix is not far away from us end-users.)

Stolea
May 19th, 2008, 04:48 AM
Thanks for the help. Unfortunately none of the suggestions helped. Seeing that it was a brandnew install and nothing was going to be lost, I did a reinstall.
Windoze has the safe desktop that will let you boot into a standard VGA setting to uninstall a patch or install a better version.
Is there a way to roll back an update?

iaculallad
May 19th, 2008, 05:02 AM
If its the "Kernel" update, fortunately on newer kernels, Ubuntu offers a rollback option. Update manager will not automatically delete installed old kernel. If problems comes along, you can easily boot into the old kernel via the Grub menu at boot up.

Stolea
May 19th, 2008, 09:40 AM
This is the current version of 8.04. I would imagine that its the latest version.
The grub lists ubuntu, ubuntu recovery?, ubuntu memchecK? and windoze.

vrangforestillinger
May 19th, 2008, 05:07 PM
Seems to me the nvidia-driver is causing the problem, since it worked before you downloaded the driver. (You had to enable the driver in the restricted drivers menu?) When you are finished booting into the loginscreen, press Ctrl+F1. This will give you a commandline interface where you can change the screensettings.

If Ctrl+Alt+F1 does not give you a commandline, you can go into ubuntu recovery, which is a command line with root access. (I.e. no need to use "sudo".)

Once you are in a commandline, you can set the xserver back to generic settings by running

sudo dpkg-reconfigure -phigh xserver-xorg
If you remove the -phigh, you will be able to configure more aspects of the xserver manually (keyboard etc.).

Now, go back to the login with Ctrl+Alt+F7. Restart the xserver by pressing Ctrl+Alt+Backspace. (Or reboot into normal ubuntu if you are in recovery.) Hopefully, the GUI should work now when you login.

You can remove the now unused nvidia-driver with

sudo apt-get remove nvidia-glx-new
assuming that you are using the new driver. There is also nvidia-glx or nvidia-glx-legacy.

Hope this helps. Otherwise, its beyond my knowlegde. Good luck!

vrangforestillinger
May 19th, 2008, 05:10 PM
Oh, I see you reinstalled. Oh well. Hope you got things working.

Stolea
May 19th, 2008, 11:36 PM
Thanks, I will keep a note of this suggestion. It would seem that my Nvidia card doesn't like that driver. In that desktop setting where you can define the graphics it will only let me use the basic setting. I guess its better than a blank screen. Its an Asus (Nvidia) 9550 128mb. Only about 12 months old.
I never thought that I would ever have to work with command lines again. Its fun though and gets the brain working again. Bit like rediscovering a lost cellar. :)