View Full Version : [xubuntu] Graphics card and Fatal error?

May 18th, 2008, 05:28 AM

I've set up Xubuntu on an old Pentium 3 for my step-son. I've been using Ubuntu for about a year now, that's loaded on the Pentium 4 machine (Ubuntu 7.10).

My question - this old Pentium 3 machine has an ATi Mach64CT graphics card.

Currently I can only get 800X600 resolution on the small 14 inch monitor (Daewoo CMC1502B).

I want to improve this to get at least 1024X768. I know the monitor can do it, I used it before on Win XP and on Ubuntu 7.10.

Can anyone please advise on what driver to download or something? Clearly some bit of software just isn't right and I'm sure that if I can identify what this card needs, the use of the computer will be improved greatly!

Oh, I did try the sudo dpkg-reconfigure -phigh xserver-xorg command. I end up receiving:

FATAL: Error inserting battery (/lib/modules/2.6.24-16-generic/kernel/drivers/acpi/battery.ko): No such device.

This is a desktop computer - no battery as a laptop. What could be the cause? It's a fresh install, just a couple of days old.


May 18th, 2008, 05:32 AM
you might try:

sudo dpkg-reconfigure xserver-xorg
i'm not sure why it cares about a battery. Otherwise you can go in the /etc/X11/xorg.conf file and manually type in "1024x768" where you see the listed modes.

May 18th, 2008, 02:50 PM
When I go into /etc/X11/xorg.conf, there are no listed modes. That's also a problem!

The graphics card is an ATi Mach64CT so it's not new, but it's not some alien piece of trash either.

No, it doesn't make sense why a desktop computer should care about a battery - it's almost as if something is configured to be a portable when it's just a stock installation of Xubuntu 8.04 (just a few days old).

May 18th, 2008, 11:11 PM
can you post your xorg.conf?

May 19th, 2008, 01:31 AM
I tried powering up the computer and tried to log in to it.

I cannot post the Xorg.conf file contents though, not yet anyway...

During the boot process it has started jumping into a text mode, then it pops up a window complaining that it's running in a Low graphics mode, offering to me the choice to configure, test or continue.

When I click on Configure, I can tell it the monitor type and the graphics card type and I can reach the point where I can set preferences for 1024X768@75Hz. But it is meaningless because one I click "Continue" it struggles some more and ends up back at 800X600@61Hz.

Eventually it will reach the Xfce login screen but only after struggling with itself for about 8 minutes. This is only after updates have run.

Now I've lost the wireless networking it had though!!

So I can't even post the Xorg.conf file contents from it now (because it's in another part of the house and only accessible through wireless).

I think I'll have to reinstall Xubuntu from scratch because between display issues and now the wireless connectivity, it's just become a big mess (shame because it's a really nice operating system too!).

May 19th, 2008, 02:23 AM
i had a similar problem when i did my upgrade from gutsy and also when i tried to use the realtime kernel. the problem was that the kernel modules were not for the kernel in use - they were for the kernel i was using previously. try choosing a different kernel in grub when you boot if you can.

May 19th, 2008, 04:27 PM
I reinstalled the whole system this morning. It seems that if I let the automatic updates run, something throws the wireless USB network adapter off line and the machine cannot reconnect, it cannot even find the wireless adapter at that point. So I'll leave automatic updates OFF.

Funny but when I run the installer it only will run in Safe Graphics mode, I cannot run the live CD or the installer as a "stock" mode installation.

Below is the content of this machine's Xorg.conf file. Please keep in mind that the graphics card in this old Pentium 3 (550 MHz, 512 MB ram) is an ATi Mach64CT and the monitor is a 14" Daewoo CMC-1502B:

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"

May 20th, 2008, 02:21 AM
I installed fglrx today and attempted aticonfig.

Even with the fglrx driver and what appears to be a suitable Xorg.conf file, the machine will still not properly use the Mach64CT card installed.

During startup when the Xubuntu progress bar is about 99% done, the machine will jump into text mode, blink a few times over the span of a minue, then pop up a low graphics mode box, asking me to configure, test or continue.

That is with a more filled-out Xorg.conf file.

If I leave the Xrog.conf file as plain and barren as you see in the post above, then the machine boots normally and doesn't sputter and cough on the ATi driver.

Go figure!

May 20th, 2008, 03:47 AM
Weird, i know xorg in hard is suppose to be more intuitive and require less in the xorg.conf. I thought that you could still choose to write a full xorg.conf though. That is strange, maybe it's a conflict between a setting it is trying to autodetec and one that is manually set in the longer xorg.conf file.

May 23rd, 2008, 01:50 AM
I've changed the graphics card from an ATi Mach64CT to a Matrox G45+MDVA16D hoping that somehow something might work and allow more than an 800X600 resolution on a 14" monitor (which I know is multi-sync capable).

No luck. :(

What driver should work with the Matrox G45+MDVA16D? And I still cannot reconfigure the Xserver, I still get that Fatal error about the battery.


May 23rd, 2008, 03:37 AM
I solved it. I researched into the Matrox card and what Xorg.conf file others used. I copy and pasted it into my own Xorg.conf file, changed it here and there (cut and try approach) and it is finally working as it should.

What a pain!

May 24th, 2008, 02:57 AM
(duplicate post)