View Full Version : [ubuntu] Installation Problems (I think SATA)

May 17th, 2008, 05:06 PM
Hey Guys,

I dled the x64 bit Ubuntu 8.04 Tried to install it and it went to the initramfs prompt, I think it's not seeing my hard drive because of the SATA controller, Controller info is as follows:

Vendor: ‎nVidia Corporation

Description: ‎MCP65 SATA Controller

Media class: ‎IDE interface

Bus: ‎PCI

PCI domain: ‎0

Bus PCI #: ‎0

PCI device #: ‎10

PCI function #: ‎0

Vendor ID: ‎0x10de

Device ID: ‎0x045d

Sub vendor ID: ‎0x147b

Sub device ID: ‎0x1c39

Module: ‎ahci

Can some one please help if you are in the US I will call you if you have the time, Thanks,


May 18th, 2008, 04:10 AM
It should detect your drives fine . What other hardware do you have and did it display any errors?

You may try using these boot parameters as they have fixed this issue for a few users. Here's how: Just hit F6 at the first menu on the Ubuntu disc and add

all_generic_ide floppy=off irqpollto the boot options.

May 18th, 2008, 04:36 AM
The problem actually is that it doesn't seem to see the SATA drives with certain controllers. It's got to be more complicated than that because the irqpoll parameter alone solved it for me. Additionally I could ALSO solve the problem by disabling USB legacy support in the BIOS. I'm still not sure why that works, but when I'm using a USB keyboard, I can disable legacy support and everything works fine without passing any parameters.

I have two computers that require this, an MSI AMD 64 system, and an Intel motherboard with a quadcore processor. So it happens on several models of motherboards.

May 18th, 2008, 12:30 PM
Thanks guys I will give that a shot and see if it works, Appreciate the help very much I love ubuntu and was very upset by not being able to install it.

Thanks Again,